Drafts 31 Released: Interface Refresh, Notion Support

Drafts 31.0 has been released:

Details below. For a complete history of updates, visit:


What’s New

Interface Refresh

Lots of general usability and interface and improvements, including updated icons, some button re-organization, and a variety of new features. Highlights:

  • iOS:
    • Quick Search is now in the top toolbar. Note that you can tap and hold on the search button for quick access to “Find in Draft…” as well.
    • Menus to load workspaces and action groups are now (v) down-arrow menus at the top of the list. If you would also like to access from the bottom of the screen, enable workspace/action group bars in (...) list options
    • The (i) detail button was removed to reduce clutter. Long press the draft icon at the top left of the editor and select “Get Info” to access draft details.
    • Actions can be accessed from the Action Bar above the keyboard without loading the action group in the bar. Tap the group icon at the left to select groups, and each group has a list icon along with it which will open a menu of actions in that group. This makes it easy to access seldom used text manipulation actions without swapping out the group displayed in the action bar.
    • New options (in Aa editor settings) to toggle visibility of the word, character, and selection counts. These can also be toggled quickly by long-pressing the Aa button.
  • Mac:
    • Workspace and action group bars are now available at the bottom of the list panes for quick access to loading groups and workspaces in the lists. These can be toggled on and off in the View menu.
  • Configure Window action step. Provides an easy way to create actions that configure the editing window, hiding/showing side panes, switching pinning/link mode, and loading workspaces and/or action groups. Great for jumping to a particular workflow. (more)
  • Show/hide character, word, and selection counts. Options in the Aa editor settings view. These options can quickly be toggled using the long-press menu on the Aa button.
  • Focus Mode is now Pinning. The “focus” name was a bit confusing, and the eyeball icon did not clarify what it did. Apple adding the “Focus” system feature didn’t help, either. This mode has been replaced by the “pinning” option, which pins the current draft in the editor, temporarily disabling the “new draft after” timeout. (more)
  • New setting available to control what happens in the editor after an action’s “After Success” setting files a draft in the archive or trash. The default is to open a new draft, but, optionally, the “next draft” from the current draft list can be loaded. This was a feature of focus mode, but one that few people knew about.
  • Workspaces Backups: Workspaces are now included in periodic backups. Options in Settings > Backups. (more)

Notion Integration (Beta)

This version introduces basic integration with the Notion online project management system. Notion’s API is still in beta but has become stable enough to start offering integration in Drafts. Be aware that aspects of this functionality may change or stop working if Notion makes changes in its API during the development process. We also plan to expand functionality based on feedback, so if you are using Drafts with Notion, please let us know other features you would like to see added.

This initial integration provides:

  • Notion Action Step that allows easy configuration of actions which create or append to pages in Notion as either text or todo lists.
  • The Notion script object, which provides access to the entire Notion API for advanced use cases.

For details, example actions, etc., see our Notion Integration Guide.

Maintenance Tasks

New “Maintenance” view in Settings/Preferences. This view is a home for completely optional periodic maintenance tasks to help restore defaults, clean up data you may no longer care about, or improve performance. Make sure you understand what the tasks do before running one because some are destructive and not reversible. Details on available tasks in the User Guide.

Other Changes and Updates

  • All Platforms
    • Change: Action steps configurations can now be viewed as read-only in the free version to allow for better content review.
      • Fix: Revamp handling a number of text modifications in the editor, both via the editor script object in actions, and via autocomplete, auto-match, and list completions, to better participate in the editor’s undo/redo stack and avoid a few cases where undo could stop functioning.
      • New: WordPress action step now includes the option to specify whether user comments should be allowed on the resulting post.
    • Fix: Autocomplete canceling when typewriter scrolling enabled.
    • New: Individual autocomplete items can be shared as URLs which can be used to installed in other installations of Drafts.
  • Scripting Changes:
    • Reminder script object now has startDate, startDateIncludesTime, and completionDate, and location properties available.
    • editor.focusModeEnabled deprecated, and replaced by editor.pinningEnabled (still works, may be phased out on future release)
    • FileManager.exists method
    • ActionLog.status readonly property to indicate status (“completed”, “failed”, etc.) of the log entry.
  • iOS
    • Fix: Clearing search in the action list would not reload the last loaded group if a group had not be selected since cold start of the app.
  • Mac
    • Fix: Issue deleting actions shared to the Directory in the “Manage Actions” view.
    • Fix: Paragraph numbers not always redrawing on scrolling.
  • Apple Watch
3 Likes

“Long press” is a hidden feature, therefore not easily discovered by users. Replacing a button with a long press is a particularly bad idea.

2 Likes

One of the minor but useful updates in this release to note, is the ability to access all your actions from the action bar, without having to swap out the group loaded in the bar. Great for accessing those infrequently used text manipulation actions and the like:

Another noteworthy change, is the workspace menu (and action group menu) moving to the above this lists. This was an oft-requested change.

If you want access to quick workspace and action group switching at the bottom of the screen, you an enable workspace/action group bars in (…) list options.

Note that the workspace/action group bars are now available in the Mac version as well:

I just did the update on my MacBook Pro, and when I type to add a tag, whatever letter that I began typing changes to something else and there is no way for me to complete the tag word that I was trying to type.

@agiletortoise

Issue with tag entry.

I have the same issue as @waynang5 on my MacBook Air (macOS Monterey 12.2.1). It seems to work fine on i*OS.

The problem appears only when trying to enter a new tag when it starts with a letter combination that is not already in use. I have found that (as a workaround) starting to type the new tag name with a # at the start, completing the name that you want for the tag and then deleting the # does work. Also, if you type faster than the matching tag list can appear, it works successfully.

In the GIF below, I am entering test as a new tag (no tags in my current list start with test)

CleanShot 2022-02-25 at 17.48.09

1 Like

Got it, thanks. Will get out a hot fix.

3 Likes

I’ve been getting the following error when trying to run any ThoughtAsylum actions since the update:

In the last couple of weeks, one user on Twitter flagged this to me, and another on the Drafts Slack group. It seems to have been intermittent and not even affecting all devices (running same versions) for one of the users. If I can reproduce it, I might be able to start closing in on what’s going on.

There haven’t been any updates pushed out for the library and actions in the past nine months (:roll_eyes:), so it should not be anything changing in there that has triggered this. But, I’ve been running the betas and it also hasn’t occurred for me just yet. In fact I’ve just downloaded the latest public release to my iPhone and tried a few actions there and I still don’t get any issues.

There is obviously something going on - there are three people who have reported the issue now. But, after looking at this over the last few weeks I’m drawing a blank on what to try next as to what I can do if I can’t reproduce it to investigate it.

Could there be any common factors (software/hardware versions, etc.) between you, @FlohGro, and richard.h from the Slack group (is that @richardh, or @RichardHanmer on this forum?), that are perhaps not prevalent to other users, or maybe there’s simply been a sharp decline in the number of people using the action groups and it is affecting most Drafts users?

1 Like

Hi, Drafts 31 installed without a hitch on my MBP M1 but on my Mac Mini M1 it gets to 90% and will not complete. Any suggestions? Anyone else got this problem? TQ

Not an uncommon Mac App Store install glitch. Sometimes just a reboot and it will work, but the most reliable way to fix is to drag the existing installation of the app from the “Applications” folder to the trash, and try again.

1 Like

Thank you, I just installed the “hot fix” and it’s now working like a charm!!

1 Like

I followed your suggestion to drag the existing installation to the bin. The reinstall worked like a charm. Thanks for the helpful, timely, advice. Andy

1 Like

Thank you for the detailed reply, Stephen. Is there anything I could do to help? I would send you my logs but I’m afraid TA actions are the only way I know of accessing them hehe.

Send me a DM on Twitter if you’d like - I’m @NeoYokel. I’d suggest email but I’m still getting used to Spark hehe.

Here’s my system information for starters
Handset: iPhone 12 Pro Max
OS: 15.4 (19E5235a)

I’ll also get back on the Slack group.

Maybe let’s open a post for the issue where we can discuss this :wink:

1 Like

Find/Replace Issues

On iOS and iPadOS (haven’t checked Mac), having the following issues with find/replace.

  1. Every time Find action is triggered, options reset as follows, even if they’ve been changed in the prior session:

    • Case Insensitive = TRUE
    • Use Regular Expressions = FALSE
  2. (This may or may not be an actual issue, and – if it is – it’s limited in scope, and might not be possible to fix.)

    It appears that, if “Larger Text” is switched on in Accessibility settings, the Find UI is resizedd such that the textarea fields no longer disclose whether multiple lines of text have been filled in.

1 Like

Thanks, will take a look.

Am I just an idiot, or is it no longer possible to change the app icon on iOS?

App icon changes same as always (in Aa editor settings). If it’s not working, reboot your device. Sometimes the system icon caches get flaky and don’t display changes.

1 Like