TIP: Shortcut to Dictation for Apple Watch Ultra's Action Button

I’m new here and hope this is the right place to post this.

I’ve created an Apple Shortcut which enables my Watch Ultra 2’s Action Button to immediately start taking dictation and then create a Draft from that dictation when I touch anywhere on the watch’s screen.

I have created a link to the Shortcut so you can download it for yourself.

The difference between mine and the existing one linked in a previous post is that mine has no friction. You hit the Action button and it immediately starts recording. When you tap anywhere on the screen the draft is saved. With the previously posted one, I get friction after tapping the screen: having to tap Allow to save the draft. Oddly, clicking “Always Allow” does not stop the pop up from appearing after each use.

I hope you find this useful.

Note that if you do not have a Watch Ultra but just a regular Apple Watch, I believe you can map the Shortcut to a Complication. However, when you tap the Complication, you’ll get one piece of friction: a popup confirming you want to run the Shortcut. It’s a big button that says RUN. Tap it and the Shortcut then functions as intended. I realize that that’s the same number of taps you’d have to do to use the built in Drafts complication, but the RUN button is considerably easier to tap than the dictate microphone, which I find too small to accurately press when cycling or walking.

1 Like

This is a great solution to save some fiddling. It’s worth noting, however, this method will not work unless your paired iPhone is present and available.

I’m a bit confused at this, as it disagrees with my testing. I’m with an Ultra 2 with a cell plan. I can’t speak for non-cell-connected Watches, obviously, but assume that it would NOT work, but also thought that goes without saying.

I just did a 3 mile walk without my phone and did a test every half mile or so and all my notes were on my phone when I returned.

Where they on your Watch? I would expect that this shortcut would actually be running on the phone and if I test it with my phone disconnected (WiFi / Bluetooth off) it does not run for me.

I didn’t check earlier as I’ve only been using the Watch to capture and just assumed that when the Shortcut told me it was finished that it had to be there. Checking now they’re all there.

I will test again tomorrow when I can separate myself from the phone and see.

Nothing to add here except to say that I just found this thread – via search!

Perfect timing, Lincoln!

1 Like

Okay, so I did some more tests and here’s what happened.


  1. Phone on but not with me.

I took a 60KM bike ride with just my Watch Ultra 2. Phone was left on but at home. I did multiple tests of the Shortcut with the Action button. The furthest test I did was 30KM from my house. The longest recording I made was 70 seconds.

NONE of the drafts appeared in Drafts on my watch. ALL of the drafts were on my phone when I returned and then appeared on my watch after it synched.

  1. Phone off.

If the phone is off, whether it’s close to the watch or not, whether or not the watch is on wifi or cellular, the Drafts do not save at all.

  1. Phone is on but in airplane mode.

Doesn’t work. Functions as if the phone is off.

  1. Phone is on, in airplane mode, with wifi connected


  1. Phone is on but not connected to Wifi


  1. Phone is on with wifi on but Data is turned off


  1. Phone is on without wifi and with Data turned off

Does not work.


As far as I can make out, as long as your phone is on and has some connection to the internet (cell or wifi), my shortcut will work for getting drafts to your Drafts, regardless of where the phone is in relation to you. However, you will not have access to those saved drafts until you’re close enough to your phone again for it to synch.

1 Like

That all makes sense and jibes with my expectations, although I did not realize the connectivity would work over cellular. I thought the devices had to be on the same WiFi or within Bluetooth connectivity range - so that’s good to know, and also makes me more curious how Apple is maintaining some sort of tunneling between the devices.

Thanks for doing all that testing! Very enlightening!


Encourages me to keep with cellular on my next watch. Does anybody know if Ultra 2 has a cellular option.

Yes. It’s only available in one model, which has cellular.

1 Like

I keep getting an error that speech recognition is not currently available on the watch. I went in to settings unchecked it and rechecked it. Restarted my watch. Same error. I can launch Drafts on the watch and tap the mic icon and it works.

The first time you run a shortcut that uses dictation, it asks for permission. Sounds like maybe permissions issues specific to the shortcut. If you edit the shortcut on your iPhone, in the Shortcuts app, and look in the (i) screen, “Privacy” tab, what does it look like?

I picked allow access the first time. It is set to Allow this shortcut to access Speech Recognition and allow running when locked.

Could you clarify as to whether or not you’ve installed the linked Shortcut and enabled it? Sounds to me like you’re describing the functionality without this shortcut. This is what motivated me to make the shortcut in the first place.

Yes, I have installed the shortcut and set it to launch on the press of the action button. When I press the action button I get the popup “Shortcut Dictate 2 Drafts” then the error message “Unable to run shortcut Speech recognition not currently available.”

I have the drafts complication capture with options setup, and it works to capture when I press the mic button.

Can you successfully run the “Dictate 2 Drafts” shortcut on iPhone, just running it directly in the Shortcuts app?

Just tried and no I can’t. Get the same error. I did some searching and can’t seem to find a solution.

Which version of iOS and WatchOS are you running? Can you go into Settings > General > Software Update on both devices and ensure there are updates available? I’m running latest on both without issue.

Okay, found the issue. I had to change the language under “Dictate text” from default to English(United States), now it works. Thanks!

1 Like

@agiletortoise, any chance of enabling Double Tap on the Watch to hit the Done button? Would be fantastic for this Shortcut when running or cycling.