Post iOS 16 update - Tag entry in single Draft Auto-complete feature/functionality removed?

Version: 32.2.1 (101) *
OS: 16.0
Device: iPhone

I also posted this on the getdrafts forum - sans my device ID

Topic: Tag entry in single Draft Auto-complete feature/functionality removed?

I updated my iPhone to iOS 16 yesterday. Before the update - or sometime very close yesterday - there was a helpful and expected behavior when I add tag(s) to an individual Draft. Post-update to iOS 16, Drafts is not doing this expected behavior.

When I click in the tag entry box, and type the name of an existing tag, it doesn’t populate with a drop-down list of suggested tags.

Thanks for a fantastic product!! I use to many times a day. On average I write or record ~1250 words per day.

Brett Ellingson

P.S. - to forum moderator(s)
Please feel free to add tags and/or move this post to a more appropriate sub-group.

Technically, this is an Apple bug, as any regression in the OS that breaks something in a shipping binary, is a platform bug.

If you are an early adopter, you might want to run the iOS 16-ready public beta, which does not have this issue.

Understood. I worked for a couple years in a software development environment. We didn’t have to deal with the diverse release requirements y’all face with multiple OS’s like iOS, iPadOS & so on but I can sympathize at bit.

Clarifying question: will that feature - the drop-down list of suggested tags - be available once the prepared versions y’all have queued up are released?

UPDATE1 ~90 min after the original post: I have no clue what happened. I did not update drafts and I did not update my iOS. Maybe drafts auto updated?? anyway, I digress.

The drop-down suggestions of the tags, is working now.

UPDATE2 ~3 min after UPDATE1 - and now the drop-drop suggestions of tags is NOT WORKING

UPDATE3 - I finally was able to open my iPad and the drop-down suggestions are working (at least for now)

It should work in the new version of Drafts as it is a standard feature of the app and that new version has been compiled and tested for iOS16. I would add that it is working for me with Drafts 33 on iOS16.

Just keep in mind that you are currently running software that is not for IOS16, so it may exhibit unusual behaviour such as you have described in your updates above.

Since you have already switched to iOS16, Greg has suggested you could switch to using the Drafts 33 public beta version. It just requires you to follow the instructions in the information he posted.

It is worth noting that you can always replace the Testflight version with the app store version should you wish to revert back to the previous version. I have done that when early beta versions of apps broke something I relied on (later ones, I could simply select to switch to an earlier beta if it was a later break).

The iOS 16 bug that causes this is somewhat intermittent. It’s a weird thing about changes they made in the timing of some system update calls.

The bug should not happen at all in the beta version, as we worked around this issue.