Drafts Widget doesn’t work in iOS and iPadOS 15

After the IOS update on my iPhone and also the iPadOS update on my iPad the Draft Widget shows only the grid of the widget, no text or symbols. May be „dark“ text on a dark background?!

Try a reboot, and if that does not fix remove and re-add the widget. These are system-level issues that have persisted since widgets were introduced last year. Getting more rare, but sometimes the widget settings just get hosed, especially around update installations.


this should be a default reply :joy:

Widgets … reboot retry

iPadOS: problem solved… windows style (aka reboot)
iOS: reboot doesn’t help. I’ll wait for self healing :grinning:

1 Like

Did you not try the remove and re-add that Greg also suggested if the reboot did not work?

I removed the widget and after this I added it again on my iPhone. Doesn’t work.

I had this same problem when I included one specific workspace in my widget. I never figured out why. I stopped including it and the problem went away.


Hello scottaw,

thx for the hint. I’ve throw out „Inbox“ and the widget worked!

Clearly there is something wrong. May be the widget is waiting for a connection to a workspace?

Interesting. What is the configuration of that workspace? Totally reproducible if you re-add that workspace?

1 Like

Normally I use my own workspaces for the widget but for testing purposes I tried „Inbox“, which is preselected. I cant see the configuration of „Inbox“ in „Manage Workspaces“. Yes - it’s reproducible.

How many drafts are in your inbox? Is it really huge? Wondering if there’s some performance bottleneck.

The Badge (Inbox) shows 624 entries.
If I select another workspace (2 entries for testing) it works.
So you are on the right path. If its a performance bottleneck it should come to an end after some time, but it doesn’t work after several hours with a selected Inbox.

There is another problem. If I try to change the widget configuration, very often the entries are not selectable, e.g. selecting „Empty“ and nothing happens.

Just to add my 2 pence… FWIW, I still haven’t been able to put up a working Drafts widget since my last bug report about it, even after successive reboots (iOS 14). Grid is empty when placed, and I can’t even edit the widget to experiment with removing workspaces (jiggle mode --» edit “Drafts” just returns to the home screen with no effect).

If it aids diagnosis, I have 8475 drafts in my inbox, total 12056 (not including trash…) :sweat_smile: Am I pushing limits?

1 Like

Wow at these numbers. :slight_smile:

If it takes longer than the (surprisingly long) widget refresh cycle maybe it never ends.

1 Like

I’m was not able to reproduce with test data, but I’m pretty sure I found a likely culprit that was causing the calculation of the workspace inbox count to use a lot more memory than necessary - and that could be what’s causing the widget to die. I’ll have that fix in the next beta build.


This would be great.
Interesting is the same environment works on my iPad Pro 10.5" (256 GB MEM) but in this case not on my iPhone 8 Plus (256 GB MEM). May be not irrelevant.

BTW: how can I test beta builds?

I have another case for this widget abnormal behavior with iOS/iPadOS 15: the default widget works, but it stops when I add a custom action with a single step (Script) that prompts to enter some data.

If instead I include another custom action (single Script step as well) that just creates a new draft and adds a backlink to another, the widget shows properly and works as expected. I definitely not have a large number of drafts in any workspace.

Seems like a bug triggered by the recent upgrade. Hints on debugging (besides removing/re-adding the widget or rebooting)?

From my experience this is not limited to Drafts.
A lot of 3rd party app widgets have issues atm
Think we’ll have to wait for the bugfix from Apple

The new beta build addresses a possible source of the workspace widget display problem discussed in this thread, if anyone has time to confirm if it fixes for their installation, it’s appreciated.