Delete unused tag

I have one tag I cannot delete or rename. When I try I get the message - “No drafts assigned the tag “status:WIP” were found. No changes were made.”

I have no drafts in the bin and would appreciate advice on removing this tag.



Does this action find anything?

It returns “No matching drafts”.

Perhaps I should have added that the “WIP” is upper case and if I try to add a tag “status:WIP” it is added as “status:wip” and both appear on the list of tags.

Tags are not case sensitive.

The action should have pulled any draft with the tag.

Next step close (force close on i*OS) the app. Reopen it. Check if the tag is still listed.

I force-closed the app and the tag still appears on the list

The screen shot shows the tag as status:WIP

Thank you for your help with this.

So when you long press on the tag and select the option to delete, that’s when you get the no drafts assigned to the tag message, right?

What happens if you purposefully add it to a draft and then try deleting it?

That is correct.

When I try to add “status:WIP” I am unable to do so because “status:wip” is added and I end up with both.

That would seem to indicate case sensitivity has been applied at some point in the past. Maybe there’s been a bug around that?

So the next thing to try would be to rename the tag to something all lower case. First, try renaming to something unique. If that fails, see if it will let you rename it to an existing tag (maybe create a new tag on one draft for this purpose just to be safe).

I tried that too and it results in the same message about it not being assigned to a draft. I can’t delete it and I can’t rename it.

I can’t think of any other in-app options to try. The tag should not exist and the validatios to support this are stopping it from being removed. Unless anyone else has an alternative suggestion, I think this requires a lower level fix - but it would also be interesting to know how it got created in the first place.

Thank you for your help with this. I think it was a typo when I first started with scoped tags but now I don’t understand how it could have been created.

Try running the “Rebuild Tag Cache” maintenance operation in Settings > Maintenance. It should fix you up.

1 Like

Rebuild Tag Cache worked, thank you.

No option “Rebuild Tag Cache” in Drafts Settings > Maintenance :disappointed:

Can you post a screenshot? Should be at the bottom.