X-callback-url append or prepend not working on Mac

I’ve confirmed that: drafts5://open?uuid=E19DA953-08AE-428D-8753-0AAA37E3EFE4 works, but when using append/prepend actions, I get Draft Not Found for UUID error


I confirmed that the same URL works in IOS

MacOS 10.15.7
Drafts 22.0.37

Hi @ansont

welcome back.

For me It is hard to understand what the error is you are facing


Please try this:

  • open the drafts to append
  • goto info
  • copy UUID
  • paste it in the code above
  • retry

I would li’ve to hear from you.


Cannot reproduce here…what steps were you taking to test?

  1. I created a new draft
  2. copy uuid from details button/popup
  3. in terminal: open drafts5://append?uuid=C9117EBB-0B76-4C6F-9EDE-9FDAE856F34D&text=abc
  • Drafts brings up dialog: URL Error/Draft not found for UUID
  • OK: I found out that it works in Safari (but not from bash)
  • However: open drafts5://search?query=abc works in terminal/bash


DId you put any text in the draft? A draft is not actually saved until it has some content in it to avoid accidental blank drafts.

Yes, the problem is with opening the url from terminal for some reason. I tried it with the same URL in Safari and it works, just ‘open drafts5://append’ (prepend and replaceRange) that appears to fail. I tried other draft5 urls in terminal, like search, those works.
I can send you a screen capture of my repo if it helps.