Why won't series 3 apple watch synch note changes?


#1

I’m just using the base version of Drafts 5 at this point and I have tried and given up on it at least 3 times over the last 6 months because my series 3 apple watch won’t synch changes I make on my iPhone 8+. It also sometimes mixes up the order of new additions that I “append” to existing notes (on the watch).
The second problem is not deal breaker but the first is. After screwing around with this app for hours (trying to get it to synch properly) I finally stumbled on a workaround. If I toggle the “flag” button on the Apple Watch it will immediately synch with the latest version of the note on my phone. This works but I shouldn’t have to do this and, I shouldn’t have had to waste hours trying to find a way to “trick” the app into synching. Does anyone have any insight into this issue.


#2

Hello!

I have the same situation, but only after upgrading to WatchOS 5 and iOS 12. Changes on the Watch are pushed to the iPhone without any problems. But changes on the iPhone or new drafts only apppear on the watch after changing an existing draft or adding a new one.

So far I did this (after reaching out to Greg via Twitter)

  • remove app from Watch.

  • reboot both devices.

  • re-add app to Watch.

  • launch Drafts, create a dummy draft, return to home screen.

  • launch Watch app.

But it does not work…

Really annoying.


#3

Something about the watchOS 5 install/update process seems to be causing problems with the connection between the watch and the phone for users. Have a few issues like this around major OS updates (and sometimes around app updates), but seems to be worse this time around.

I don’t think it’s anything the app is doing wrong and I’m not getting any crash logs that are related or anything - but I’m watching it (pun intended).

The steps @Chrome listed have always resolved connectivity issues in the past…but there may be something else going on for some. Those steps are the first thing try.


#4

Good to know you guys are on it. Toggling the flag button is an OK workaround for the time being. I was wanting to put this on my elderly mother’s first smart phone (and Apple Watch) because it is just about the simplest way I know of to make appendable notes and lists on an Apple Watch without typing (when it works right). I’ll just teach her the workaround.


#5

P.s. I’m pretty sure I was running into similar problems before but, now that I think about it, it may have also been around a previous watch update.


#6

Only wanted to add:

  • communication between watch and iphone is perfect for me, I think even better than before. Changes made on watch are passed instantly to the iphone.
  • Changes made on the iphone are not passed back to the watch. Only with flagging items or adding new ones on the watch seems to reestablish communication between the two for this moment.

Thank for looking after this!


#7

Issues here. New Xs phone, new series 4 watch. There’s no communication between drafts on watch and iPhone. Nothing from phone shows up on watch, new items on watch don’t show up on phone.

Toggling flag doesn’t help


#8

Try force quitting the app on Watch. I’ve been walking through scenarios to trigger the problem (pretty sure it’s at the watchOS level - but hoping to find a workaround) and that restored the connection successfully in my tests yesterday.


#9

Must be an os problem, it was happening with things 3 too. They have “reset things sync watch data “ button buried in their phone app settings. That fixed their sync problem for me, and also the drafts problem as well. Now that’s a case of collateral fixing!


#10

Only wanted to report that with watchOS 5.01 nothing changed wird misbehaving sync.


#11

I am having the same issue XS Max and S4. Tried rebooting and reinstalling. Force quitting the Drafts watch app or adding a new draft forces it to sync.


#12

The last update brought an improvement to syncing between iPhone and Watch. Not quite as good as before WatchOS 5, but definitly better I think, than before the last update.

Backward syncing of items from the iPhone to the Watch still does not work automatically. I have to open the Watch App and need to tap Inbox there to update the Icon count and show the new items added on the iPhone. But before the update even this did not work. So thank you!!

The situation is better now but still not on par with Drafts and WatchOS 4. Any chances for further improvement?


#13

I am running Watch series 3, Macbook Pro, Ipad pro, and Iphone 7 environment. All have most recent public beta OS and latest drafts beta versions.

Synching in all directions seems to be working very well. I just ran a test to create new draft on Mac and it showed up on watch almost instantly with the inbox on watch automatically updating.

For anyone using public beta software, be sure you install the beta profile on the watch, as well as the iphone.

Bob