Why aren't Templates working?


I am having issues with creating Templates in the usual way I and don’t know why.

I’ve added a Workspace for templates and have tagged my templates with ‘Template’ and yet I am getting an error. I don’t understand why.

Any idea what is going on here?

Superficially, looks right.

Have you made any edits to the original action? Have you tried installing a fresh copy from the Directory?

Yes I did upload a fresh directory and had the same error message. That’s why I was confused and thought that I was doing something wrong. :thinking:

Every time I try it, I get the same message.

Has this worked for you and stopped working? It seems mostly likely there is some mis-match in the tags - maybe a hidden character mistakenly included in the tags or similar.

Yes, it was working in the past, but I haven’t used the recently until now.

Very odd for it to just stop working without anything changing to precipitate the change. A reboot of the device is always worth a shot when things mysteriously change.

I’ve put a quick action together that will count your Drafts with the template tag can you run it and review the results? It should match the zero results for “template” in “all” to match the workspace generation.

If not, next step is to take a look at what the temporary workspace generation in the Action is gathering/filtering to.

1 Like

First… Amazing. And Thanks for that.

I ran the action and it told me the following:


I am not sure what this is telling me - Perhaps you can translate Stephen.

I was trying to figure out how to check the ‘Tags’. Is there a master Tag area that I am missing somewhere? I seem to remember that there isn’t, and that tags are created and adjusted on the fly… but I could be wrong.


The original action uses “template” for the tag, and “all” for the scope. So it tells us the temporary workspace should find 4 templates.

But, the error message you got tells us the workspace filters to 0 drafts.

I have to work shortly so will return to this later if there’s still an issue, but can you double check you have just one instance of the original template action and that you are not inadvertently running a different version of the action to the one Greg referred you to? That will just help rule out another “what if” scenario.

1 Like

The action below pulls out the pertinent item of data from before (lowercase “template” tagged drafts from the “all” folder) as ‘DIRECT’. It then builds the temporary workspace exactly as the original action does (it uses the same code (other than an extra error message being included), and counts the number of drafts. This ‘WORKSPACE’ number should be the same as the ‘DIRECT’ number when everything is working okay.

The action then goes on to list out the titles of any drafts in the workspace. Just to explicitly be able to identify what if anything is missing (if only some were being found).

Here’s some example output when I run the action so you get an idea of what it might look like if things are working as intended.

This is the lowest effort option I could think of to check this stuff, so do try it, and don’t forget the points at the end of the previous post.

Now, if you do get zero results for the Workspace output, can you try creating a workspace in Drafts with one criteria - the inclusion of a tag “template”. Something like this would be sufficient, and then see what you can see in that workspace.

This takes a little more effort and has more oportunity for error, hence I went with the action first. However, checking this will let us see what Drafts “sees” when it runs the action and will also confirm other factors such as your Pro subscription still being in place to let you use advanced features like workspaces.

Post back with how you get on.

1 Like

I’m not ultimately sure what part of this worked and having reviewed everything I couldn’t see anything different, but somehow in the whole analysis of this problem it appears to have resolved itself, in no small part due to your help. So thanks very very much.

Golden again.

1 Like