Web app prompts for my credentials allows me to enter text then hangs on create draft


As I would expect I am asked for my Apple ID and password to authenticate to use Drafts which is no problem but for some odd reason it successfully completes that authorisation I get the box to begin writing into which I do and then upon clicking “create draft” it simply hangs and it gets no further.

I am on Linux Mint using Chrome version 90.0.4430.93. It worked absolutely fine for me up until I went to use it again a few days ago and its getting no further.

I have cleared cookis and data in Chrome too.

Have you tried an incognito browser session to see if it persists in your Chrome instance, and in another browser? That should help determine where the source of the issue lies and where to focus the investigation.

Thank you for the information I have tried private mode on both chrome and Firefox and normal mode with both chrome and Firefox but both with the same outcome

Okay. I’ve just had a run around and tried the web capture service on a variety of devices and browsers.

It still works in Chrome and Firefox on Windows for me, and also in Safari on Mac and i*OS.

I’ve also just tried it on an old laptop I have that happens to be running Mint Linux, but I only tested with Firefox (v89). I.e. nothing Chromium-based. It worked fine for me on that too.

1 Like

Thanks for testing. I am unsure what’s happening then :cry:

I’m not a subscriber so not sure if it’s a feature moved behind a subscription but I’m sure that wouldn’t authenticate and give me a window to type if that were the case!

To me, given my results, it suggests it is either something local to your PC, or an issue with your Apple credentials.

Can you try it on an Apple device? That will then determine if it is an authentication issue for you, or an issue with your other PC.

Hello! Thanks. Yeah that was my thought but I’ve tried it now on Windows and two different Linux mint systems with the same outcome.

Just tried it on my iPhone in safari just now and get the same again!

It’s so bizarre!

That sounds like it is related to your account. The only thing I can think that you have access to try is a password reset; but it sounds like you are a step beyond that in what happens here.

Maybe @agiletortoise can suggest some other things to try?

Yeah that’s right. The credentials are accepted and I’m past all of that. It’s very odd. It’s not passing that text over to the drafts account. The main app on my iPhone and Apple Watch is fine.

I had one other user reporting a similar issue, but didn’t have much luck getting details. Any JavaScript errors in the web inspector? I suspect iCloud is reporting some error that’s not getting trapped to report as an alert, but not sure what.

Interesting! Glad I’m not alone. Is there a way I can replicate and get logs from my phone for you?

I’m no developer but unsure if this info helps from my chrome browser on my laptop.

Request Method: POST
Status Code: 404 Not Found
Remote Address:
Referrer Policy: strict-origin-when-cross-origin
Access-Control-Allow-Origin: *
access-control-expose-headers: X-Apple-Request-UUID,X-Apple-CloudKit-Web-Auth-Token,X-Responding-Instance,Via
Apple-Originating-System: UnknownOriginatingSystem
apple-seq: 0
apple-tk: false
Connection: keep-alive
content-encoding: gzip
Content-Type: application/json; charset=UTF-8
Date: Sat, 19 Jun 2021 16:01:26 GMT
Server: AppleHttpServer/ba512e728b68b6da7d047b7c7c12cae42f0df279
Strict-Transport-Security: max-age=31536000; includeSubDomains;
Transfer-Encoding: chunked
via: xrail:mr47p00ic-qujn01123001.me.com:8301:21D104:grp22,631194250daa17e24277dea86cf30319:e5b19f619bc5ad57448abb4b5d943e31:London

X-Apple-CloudKit-Version: 1.0

Same has happened on my windows pc too. This is driving me mad lol

Those errors sound like the network or security policy on the device is blocking iCloud resources from loading. Are you on a corporate machine/network?

The windows one was yes. Ok fact one if my Linux systems was in a work environment. Let me try on home wifi with both Linux chrome browser and windows too.

Ok so I was on a vpn before in a corporate device and now since switched off the vpn. This sadly still hangs on the same thing.

Quickly fired up the personal Linux system with no ties to work and that is also the same. Very odd.

Using google chrome as well and the latest version available on Linux too.

This is the chrome error behind the scenes on the personal Linux system. As mentioned no corporate ties whatsoever in this system.

Failed to load resource: the server responded with a status of 404 (Not Found)
cloudkit.js:14 Uncaught (in promise) tmessage: “Zone does not exist”_ckErrorCode: “ZONE_NOT_FOUND”_extensionErrorCode: undefined_reason: “Zone does not exist”_recordName: undefined_redirectURL: undefined_retryAfter: undefined_serverErrorCode: “ZONE_NOT_FOUND”_subscriptionID: undefined_uuid: “6c508c7f-5aa1-4878-a1b3-a122a871948c”_zoneID: undefinedckErrorCode: (…)extensionErrorCode: (…)isCKError: (…)isError: (…)isServerError: (…)isServerExtensionError: (…)reason: (…)recordName: (…)redirectURL: (…)retryAfter: (…)serverErrorCode: (…)stack: "Error: Zone does not exist\n at Function.value (https://cdn.apple-cloudkit.com/ck/2/cloudkit.js:14:2616)\n at https://cdn.apple-cloudkit.com/ck/2/cloudkit.js:13:23291"subscriptionID: (…)uuid: (…)zoneID: (…)proto: Error
DevTools failed to load SourceMap: Could not parse content for https://cdn.apple-cloudkit.com/ck/2/resources/cloudkit.js.map: Unexpected token < in JSON at position 0

Is the Apple ID you are logging in with in the browser the same you use for Drafts on iOS/Mac? Seems like something specific to your account, but the “Zone does not exist” message would tend to imply Drafts has never been synced to that account from the app to create the DB structures (could be a erroneous error, just imagining possibilities).

Hello, thanks for the reply. Yeah 100%

It worked fine when the feature first landed. It’s only started happening when I initially posted here. It hasn’t coincided with any changes to my account or anything. Things have remained the same.