Twitter.create keeps failing, unsure how to debug


#1

Hi. I’m very new to scripting with Drafts. I tried to use the tweet storm action (http://actions.getdrafts.com/a/1Hu), but it keeps failing at the Twitter.create() command. It fails regardless of whether I specify no arg or my Twitter identifier number as an arg. For the record, I am able to post a tweet with the standard Twitter action and I have authorized Twitter. Any tips on how to fix or even debug this problem? Thank you!


#2

Did you edit the original action at all? If you reinstall and make no changes does it still exhibit the problem? Are you updated to the 5.0.5 release that came out yesterday?

Also, the “twitterIdentifier” is just a string value. If you only have one twitter account, just leave it “” as in the action default - it has nothing to do with your actually Twitter account.


#3

Oh. That’s very embarrassing. I updated Drafts on one device and then tested the action on the other device (which didn’t have the update). Oops! It works now. Cool! THANK YOU FOR THE AMAZING APP. One of the most important apps on my iPhone and iPad… :black_heart::blue_heart::orange_heart: