Trying to recover lost text

Hi, I just wrote a long draft with several paragraphs and then all of the text disappeared. I think that this has also happened several other times in the past few weeks (but never with so much writing before). Can you please help?

I’m not sure why this happened, i was just about to copy/paste the text to omnifocus when i saw that omnifocus was not responding and required me to force quit it. I force quit omnifocus and then looked back at drafts and all of my paragraphs were gone. The tags that i just applied were still there but there was no text.

I tried using undo immediately several times but it didnt do anything. I also checked the versions button on the bottom but it didnt show anything.

Why would this happen and not allow me to undo any changes?

Is something wrong with drafts or the way that im using it that might cause this to happen on several occasions? I dont want this to ever happen again.

Is there anything i can do to prevent this in the future?

Is there any way I can recover my text? How?


Using MacOS mojave 10.14.6 and Drafts 15.2.5

Did you look in the draft list for the content and try to reload the draft? Not sure what happened, but may have been a display glitch, are you sure the data is missing? Drafts saves pretty often, so I would be very surprised if the whole draft was just gone.

Yes, I searched for words in the missing content with drafts main search feature and didn’t see it. Also tried going to different drafts and then going back to the draft with lost text and still didnt see the lost content. Is that what you mean?

As far as i can see its missing, its also not showing on my iphone drafts app. Is there anything else i should do/check/troubleshoot?

Check any previous versions of the draft, just in case.

Thanks. I just checked version history again on both mac and iphone and the only version it shows is after text was deleted. Is there any way to increase the frequency at which it auto-saves versions?

Anything else I should try?

Also, is there any way to search for tags other than using workspaces (on mac)? When i use the regular search feature it doesnt search for text within tags.

Versions are saved when selected other drafts - e.g. finishing an editing session, and in a few other cases. On the Mac, ⌘-S (File > Save Version) will manually create a version on demand. On iOS, you can install a Save Version action to get this same functionality.

Filtering by tag is available, just as on iOS, in the filtering panel to the left of the draft list.


That happened to me too about a week ago. I was typing away when the text just vanished before my eyes. I think I may have hit the wrong keys on the keyboard but I don’t know which ones. I searched for the text everywhere but it was gone. I tried to undo but that didn’t work either and it wasn’t in the trash. It’s as if it was permanently deleted somehow. I don’t know what keys I could have accidentally pressed but if it was a delete command I would think there would be a confirmation prompt popping up.

I’m a heavy Drafts user and this has never happened before or after. I was typing on my Mac running High Sierra and the latest version of Drafts. Just mentioning this as the cause may be the same as the one in this thread. I can’t replicate it though.