Tooltips for Toolbar and Action Buttons [SOLVED]

Could there be hover-to-discover tooltips for the toolbar buttons on macOS? Or the ability to add custom tooltips to Actions? Maybe it could use the existing Actions description field or a new dedicated one. It’d go a long way in enhancing the user navigation and experience.

1 Like

Not sure where you mean. Most buttons in Drafts have tool tips. In the toolbar, in the action bar below the editor, etc.

Hmm there might be something going on on my end then.

Version: 39.2.1 (269) *
OS: Version 13.5 (Build 22G74)

Ex: none of these buttons have a tooltip upon hover:

@agiletortoise should all the buttons in my previous post’s screenshot have tooltips upon hover?

Yes, very much. All standard macOS tooltips. Not sure why you would not see them on your device.

1 Like

I appreciate the video you provided. I’m sorry for pestering you about this, but I was wondering if you had any ideas as to what might be causing tooltips to not appear on Drafts on my M1 MacBook Pro? Do you have any suggestions on how I can try to troubleshoot? I’m using Alfred, BetterTouchTool, and a bunch of other 3rd party apps through Setapp. I tried quitting them all one by one, but that didn’t seem to do anything. I also make sure to keep macOS up to date and have rebooted since I first noticed this issue. It’s really strange, do you think I should try uninstalling and reinstalling Drafts?

Tooltips are working in other apps? Especially system apps like Notes/Mail?

I suppose a reinstall couldn’t hurt, but I really have no ideas - they are definitely setup in Drafts and work on all my Macs. There may be some system settings that disable them, but I would think that would be system-wide.

1 Like

Thank you very much for your responsiveness and willingness to help me.

I FINALLY figured out why tooltips were not working for me, both in Drafts and any other macOS apps like Notes. I would not have been able to figure this out without the help of GPT running locally on my machine (thanks to KillianLucas/open-interpreter: OpenAI’s Code Interpreter in your terminal, running locally (

There is no setting accessible via System Settings to check or modify the tool tip display time. However, the setting exists and is only accessible via Terminal.

This has has troubled me for over a year, and I don’t know how or why but somehow I must have had an application that altered the default time. I hope closing the loop on this might help someone in the future.

To check what your default tooltip delay time is, run the following command in Terminal/iTerm:

 `defaults read -g NSInitialToolTipDelay`

For me, this returned 100000 (i.e. 100 seconds)!!

The macOS default is 1.5 seconds (i.e. 1500). In order to change it back to default, I ran the following command:

 `defaults write -g NSInitialToolTipDelay -int 1500`

Problem solved!

1 Like