Todoist connection not working [SOLVED]

After falling off the wagon I have returned to drafts. After installing the app unfortunately my connection with Todoist is not working.

Can anyone help me reconnect the two apps. Really appreciate your help.

Try forgetting Todoist under your settings to then prompt you to reconnect the service when you next run it.

  1. Tap on the settings icon (cog) in Drafts. Bottom left corner.
  2. Select Services > Credentials.
  3. Select the forget option against Todoist.

Hope that helps

1 Like

That worked. Thanks so much!!

Tried doing this several times and still getting the same result. Uninstalled Drafts and reinstalled. Also tried resetting the API token in Todoist

FYI I have been trying to use the ‘Task in Todoist’ action but - for first time - it’s constantly failing. The Action log - attached - seems to suggest an API handshake issue but I am out of my depth - can someone please advise? (Also - I reset authorization but that did not help:(

I too have been unable to connect to Todoist. It used to work for me but stopped working. I removed the credential and even when I try to reconnect it, it is not working.

@Farb630, @Dan_Peck and @WithBBQSauce - the issues regarding the depreciation on the Todoist API were posted about earlier this week.

Thanks for the update. This was driving me nuts!

Is Todoist integration still broken? I continue to get errors with the Beta version

There is no mention of the fix being included and being a focus point for testing in the Testflight release notes. The release notes should be the definitive record of what’s changed in a release.

iOS 13 Update fixes the issue