Spell Check Not Working

Spell check stopped working for me months ago and I’m finally frustrated enough to get help. It’s checked on in Markdown settings. Any ideas?

What device is this on and if not a Mac, what keyboard are you using?

It’s a MacBook Pro circa 2016.

If you enable show spelling and grammar…


… it will trigger a check and include the underlining.


However, if you want everything underlined, I had to step through…


… then if I add more errors, it won’t pick them up with the underlining until I recheck.


This is with my draft set as Markdown and with the “Check spelling while typing” option enabled. Same result if I switch to another syntax such as plain text with the same setting in place.

If I switch to an entirely different app such as Apple’s TextEdit, I also see the same behaviour.

That breadth of impact made me rather curious, so I did a bit of guided research and ended up trying the follwing terminal command.

defaults write -g NSAllowContinuousSpellChecking -bool true

This is an OS-level setting that tools like Grammarly amend. After changing this setting, closing, and reopening Drafts I now get something more familiar looking in terms of continuous spell check.


Any chance you’ve been using Grammarly, or a similar tool, too?

Yep, you nailed it! Thanks so much!