[Solved] Keyboard text prediction and shortcuts doesn’t work

I have several shortcuts (text replacement, native function on Mac, Settings > keyboard > text) and it doesn’t work in Drafts for Mac. No problem with ios version.
For example, ‘;fi’ should be replaced to ‘for information’ but in drafts for Mac it doesn’t work.

The touch bar should display text prediction but it doesn’t on drafts for Mac either.

I have a couple of keyboard text replacements that I use and they work fine for me in Drafts on the Mac.

I’m assuming from the above path that you have checked, but can you confirm that they are all showing in keyboard settings on the Mac? i.e. have they definitely sync’d?

Do the text replacements work in other apps?

Has it ever worked for you in Drafts, and if it has, have you tried restarting both the Drafts app and the Mac? Also, if it is the case, have you noted anything about when it stopped working?

The Touch Bar is often linked to the action bar. Can you check Drafts > Preferences… > General > Show custom TouchBar in editor (when available)?

See https://docs.getdrafts.com/docs/editor/action-bar#touchbar-support

hi ! quick answer thanks ! :blush:


Yep they are all showing in keyboard settings.

Yes text replacement works fine on other application for example in brave when I type this answer :+1:

Your last link doesn’t work for me… If I uncheck the setting I got text prediction on touch bar :clap:

And then If Drafts > Preferences… > General > Show custom TouchBar in editor is uncheck and Drafts restarted all works fine ! many thanks :pray:

1 Like

Sorry about that, it looks like if I just try and post that URL, the forum truncates it and ends it with an ellipsis. Enter it as a fully defined Markdown link and it works fine. The updated URL is corrected above for reference.

And, I’m glad that one was a nice easy fix :+1:t2:

I think the app restart has more to do with getting the rest working than the unchecking, but all in for a winning combo :sunglasses:

Glad you got it all sorted.