Simple shortcut replacement

Hi dchar,
Okay, that change made a difference but the output still isn’t correct. Any other suggestions?

Thanks for help!

Hmm. This has me stumped. It looks like the number is being replaced but the digits are being replaced with :.

Do you happen to have any other “shortcuts” drafts with other replacements defined?

What version of the shortcuts action do you have?

What version of Drafts?

What if we try a couple of other “shortcuts”

# Personal Snippets

.pn: 555-555-5555
.em: 🤓
.sn: hello world

You fixed it! There was another draft with the “shortcuts” tag and a few snippets defined. When I moved that one to the trash the action started working correctly. Moving the second tagged draft back to the inbox reproduced the error. I thought that multiple drafts with the “shortcuts” tag was okay (one for personal, one for work, etc) but I can live with just one. Having this text expansion action inside of Drafts (including the template engine!), especially now that I’ve assigned a hotkey to it, is magical. Thanks again for the help and for this great action!

1 Like

Hope all is well

I read this and it has worked. When ever I come back to it it’s broken. Any idea how to rectify this problem. Love the concept and thanks for the help

What is the actually problem you see?

It works fine (?) and then you go away (to another app, other draft, another day, week, month, iOS release, etc) and then come back and it doesn’t work (?)

Just want say; appreciate the concept and your response. If I get this work; omg. Here are some screen shots of my work.

Yes; I read the instructions; read the modifications in the messages and attempted to follow the instructions. It’s probably me making a mistake. Any feedback is appreciated. I set up; it works/ I go take out garabage and come back and it does not work. Very odd

I think you have some malformed YAML in your shortcuts draft. I suggested starting with a single replacement and testing as you make changes. You could use an online YAML validator like HTTPS://

I tried what you showed in the screenshot and it worked fine.

wow this is just amazing; I do have a question with the multiple choice; is there a way to select multiple options ie; Delaware and Texas at the same time ?

Right now there’s only one selection.

Hey guys!

For the longest time, I’ve used this to replace a shortcut with alphanumerics.
Recently, this only works with characters but not with numbers, as it replaces them into something else.
I haven’t changed anything in the code.
Has anyone come across this?