Problems with actions after upgrading from Drafts4

My main use for Drafts is as the creation stage in my GTD workflow. I use on an iPhone, iPad and Mac to create Inbox items in Drafts that then get sent to Evernote for onward processing. This workflow has worked perfectly through each upgrade of Drafts - until now.

I have two problems after upgrading:

  1. I have several near-identical actions, each of which creates an Evernote note with a defined title and body. The only difference is each has a different keyword at the start of the title: e.g. Personal - [[title]]. Some of these actions work OK, others just provoke a !action redbox.
  2. Drafts for iMac (which is newly installed), found my actions but says Action not supported. Just to experiment, I created a new Action with the same action. drafts for Mac allowed me to create the Evernote action, but still says it’s not supported.

Problem #1 - Can you post details of what is in the action log for one of these failures along with the content of the draft, and a link to the action you are using?

Problem #2 - that’s going to be to do with the compatibility. Not everything works on both platforms. Some action steps only work on some platforms; though for Evernote, I think there should be some workarounds possible with x-callback-url and/or AppleScript.

Thanks, Stephen
I’ll re-create and error and post here.

Re: #2, I’m not that fussed if it’s a faff to work around. I’ll just delete Drafts for Mac: I’ve only ever used it on iOS in the past. Unless the functionality is the same on all platforms, the additional app of no use to me: there’s no way my old brain can hold differences in usage between platforms :slight_smile:

Here are the screen shots . I created a new draft and then tried my default action action: which failed. I then tried action - Genealogy which worked. This was all on the iPad.

The only difference I could see was that the failing action had a Notebook specified. However, removing that made no difference.

The images can be seen at as I don’t have the privilege to upload more than one mage.

That error (“No note content to upload”) is because you have a title (first line) and no additional text in the draft. Evernote will not accept a blank note, it generates an error. If you use it on a more typical note, with text in the [[body]], it should work fine.

There are ways to make cross-platform Evernote actions - some details in the Evernote integration guide. It’s unfortunate that Evernote’s own cross-platform support is not ideal.

1 Like

Hmm. Those actions work fine on Drafts 4 (I’ve still got Drafts 4 installed on the iPhone), so something has changed on your side if you are throwing an error when there is no body text.

The only difference between the failing and passing actions is that the latter inserts a keyword at the start of the title. However, other actions that also add in keywords fail as well.

EDIT: On closer inspection, I see that the failing action has [[body]] in the Template, whereas the working one has [[draft]]. I’ll go through and amend the failing ones.

That seems to have done the trick.

However, this is a change in behaviour between 4 and 5, so it might be worth mentioning in any migration documentation, FAQs etc.

Thanks for your help.