Printing what you see under File - Show Preview

#1

Is there a way to print what you see in Preview? Occasionally, I am writing in markdown and would like to get a quick printout for reference. If I look under File - Show Preview I would like to get a print from that version, typically I use the Swiss format. But I can’t.
Any tips / tricks available how to do that?

1 Like
#2

Exactly! I need that too and found you can copy HTML but would highly appreciate a Print… option.

(Really, I must add though that Drafts on the Mac solved almost all my previous problems. Together with other tools, s.a. Alfred, Hazel, TextSoap etc. I get by without Actions until they arrive.)

#3

From the preview window use the gear (bottom left) to copy as HTML. Follow these instructions to make a new html doc that you can open in Safari and print from there.
https://www.w3schools.com/html/html_editors.asp
The instructions seem complicated the first time but once you do it once it’s basically a 10 second process. Or less.
Of course this kind of stuff will all get automated and customizable in a coming day of nirvana once we’re putting actions on the Mac… But this is a good workaround for now.

1 Like
#4

In Preview, select all, then copy and paste into TextEdit.

#5

Ok, I copied the html and pasted it into TextEdit on the Mac (???). Then rename the file to index.htm, (don’t know how to set it to UTF-8) as requested in the article), double click it and it opens in Safari. But unfortunately just weird looking letters and not in the look that I had under “Show Preview”.
I am probably in the wrong path here, correct? Thanks for the help.

#6

On the Mac, in Drafts, open the Preview, select all, copy, switch to TextEdit, paste, print. Job done.

#7

For that day, the print the preview on Mac would become as simple as it is on iOS, with no requirement to produce an intermediate file and send to a browser. The print action step would/will suffice.

1 Like
#8

UTF-8 is a character encoding allows for saving of text with a broader character set and is useful for where you have text containing a variety of accented characters, etc.

This Apple support thread explains where to find the settings in TextEdit to change the character encoding.

If you do have accented characters, then the lack of UTF-8 encoding could explain it.

If changing it to UTF-8 does not work, it might be best to share (here) some sample content from Drafts, how it looks in TextEdit, and how it looks in Safari.

#9

Thanks for this, as a much simpler way. On the other hand, it’s loosing the full formatting of the Markdown—particularly line spacing. So if you just want the text and roughly formatted as you had it in drafts, this simpler solution is great. Or actually you could just print from the Draft itself. But if you want to accurately preserve the Markdown results you’re going to have to pull it out as HTML. Anyway, thanks for the helpful angle there.

#10

So your key here is to carefully follow the tutorial I had linked there. I’m guessing that you must have skipped the initial steps of adjusting the preferences panel? No worries. I did that also the first time. :grin: So if you set the preferences the way they say then you’re going to see a “save as UTF-8” drop down menu in the save window. Just carefully follow each detail of the tutorial (it’s up to date and accurate) and it will work.

#11

Yes, I was responding to the OP’s request for a way to “get a quick printout for reference”.

#12

I was looking for that very thing this morning myself. As you say @jarno527 it’s a shame it strips out some of the spacing. Annoying actually as mine was a simple letter - yet the address kept coming out on one line rather than being spaced onto separate lines.