Paragraph Break

When I am editing I hit the return key and I get a new line. When I convert my markdown the line break is not recognized. It takes two returns to get a line break.

I don’t want this. Where are the settings to change this behavior.

You put two spaces at the end of a line in Markdown format for just a line break. A paragraph requires one or more blank lines in between. That’s simply the Markdown syntax, there are no settings to affect this.

Ref. https://daringfireball.net/projects/markdown/syntax#p

1 Like

To be doubly sure you could code a <br/> :slight_smile:

On a related topic, iOS adds a period when using 2 spaces. While I prefer this behavior most of the time, it’s a problem when working in markdown apps like Drafts. I know this can be turned off in system settings, but is it possible to disable this feature only in Drafts?

Maybe. But probably unlikely since it is a keyboard level setting.

Consider setting up a shortcut text replacement for it (E.g.qq to be replaced by <space><space>) if you want it cross app but wish to retain the regular replacement.

1 Like

If you wait two or three seconds between spaces, iOS won’t create an automatic period.

2 Likes

Instead of waiting, I usually type the spacebar once, then the arrow key to move back one space and then the spacebar again. Extra keystrokes, but it’s pretty fast at least with a keyboard.

1 Like

My text is coming in from a shortcut so on looks like I will have to process it there to add the spaces. Does anyone know a regex that will add two spaces to the end of a line?

This action will automate it for you. Run this at the end of writing your note and it will fix up all the lines so you get what you want.

https://actions.getdrafts.com/a/1IP

Thanks, Solved it in Shortcuts for the current instance but this is more general.