New Draft with Template now displays only one template

In the past couple of days, the New Draft with Template action stopped displaying all my templates, and now displays only one (which doesn’t scroll.

Same on iPhone, iPad and Mac. Screenshots attached.




Would help if you can share a link to the action you’re referring to :upside_down_face:

Looks like it is this one based on the name and the screenshots.

That action creates a temporary workspace based on a tag (“template”) for identifying the available drafts for use as a template. It also pops up an alert where you have no matches, and I think would simple fail if you were not a pro subscriber (but that would be worth checking if you the below does not help).

Use the tag filter to filter for the “template” tag. The action will search across inbox, flagged and archived, so check them all with this filtering. How many matching drafts do you have? Just one?

1 Like

Sorry for not being clearer — yes, that’s the action to which I’m referring. Thanks for adding the link.

I’m a Pro subscriber, and Settings indicates that my subscription is active.

There are about 10 drafts in my Template workspace. I’ve just confirmed that they’re all still there. (This is an action I use multiple times every day, which is how I know it’s only stopped working in the past couple of days.)

I’ve reinstalled the action from the directory, just to be sure that the lone edit I made months ago (defaulting “omit first line” to true) wasn’t the issue. Same result.

I really appreciate the help on this!

Can you run this action and share back the clipboard results and how many drafts the action reports as being copied?

This action is using the same selection criteria as the original action, so it should match that in terms of results. But, it is also using the same basic criteria as the search option I suggested earlier. So, it should also match that. Given those two match options do not currently match, I am Interested to see where this falls.

Figured it out, with the help of that action. Thank you.

I’d inadvertently saved my default workspace with a search term.

Only one of my templates had that term.

Once I removed the search term from my default, everything worked again.

Thank you so much for your help. Heaven knows how long it would have taken me otherwise!

Note that the example action uses a temporary workspace because I did not want to require someone create/install a “Templates” workspace to use the action.

If you have a templates workspace and want the action to use it instead – and therefore not be affected by the default workspace values - you could change the action as follows:

Replace the following code

// create temp workspace to query drafts
let workspace = Workspace.create();
if (!workspace) {
	return false;
workspace.tagFilter = "template";
workspace.setAllSort("name", false, true);

with this code, to lookup your existing workspace - assumes your workspace is named “Templates”

let workspace = Workspace.find("Templates");
if (!workspace) {
	return false;