Need help with ToDoist actions

Hello,

I’m just getting my workflow integrated. Which is another way of saying I don’t have much experience with drafts other than as a way to capture text quickly and efficiently.

I’ve started keeping a log using drafts. My daily log is formatted using markdown like this:

  • H1 day and date
  • H2 ToDos: a list of all the tasks I accumulate over the day formatted with a dash and then brackets and followed with the actual task
  • H2 meeting title or project: with notes from that meant to recall my reaction and/or record what I actually did during the project work

I’d like to process my marked todos into Todoist with an action. I’ve tried various actions from the gallery – process meeting notes, list unchecked tasks.

I first I got the satisfying green bar indicating everything worked but no tasks showed up. I check, I tried tests. Nothing.

So I deleted all the Todoist actions and started again. Now I don’t even get the satisfying green bar.

I tested my general ability to run an action – I’ve moved notes to bar, shared them with the share menu, and sent markdown to devonthink.

I’m confident that I’m just making a straightforward, simple, and obvious mistake but I can’t figure out what it is. I’d appreciate any pointers as to what the issue is so that I can resolve it.

Thanks,
:mw.

PS – In case it’s helpful the broader work process I’d like to get to is importing a daily agenda from Fantastical into drafts and then have the note pre-formatted in the way described above. Then at the end of the day send tasks to ToDoist and send send the notes section to Tinderbox so I can explode them into separate blocks.

In this process meeting notes action, there is some.codw like this.

/* --- Todoist ---*/
let todoist = Todoist.create();
for (var line of lines) {
	if (line.includes("- [ ]")) {
		// Todoist Action

In the penultimate line of this excerpt you can see what it is looking for to match a Todoist action. Note the space between the hyphen and the square brackets.

You don’t mention anything about the space, so it may well be you are not giving it any matches.

Have you also disabled the Things step in the Action as per the action instructions?

Thank you for the quick response.

I did catch the space (after a few tries) and have that right in the Drafts note.

Have you also disabled the Things step in the Action as per the action instructions?

I can’t find it. When I go to manage actions -> process meeting notes -> and open the script I only see the ToDoist instructions. I have removed anything related to things from the actions (using the “-”) in the actions group.

Three other things:

  1. I no longer get any signal that the Action has run. No indicator in Drafts (what I get when I run other actions) and it does not show up when I open the Actions Log. Edited to add: I do get success for processing the action if all items are checked. If one is unchecked, I don’t get any acknowledgment (not even an error) that the action was run.
  2. I tried – and failed – to find where the actual file is located on my hard drive (versus editing with the built in manage apps work). Maybe that’s what I need to find and how I need to edit the file?
  3. The first time I ran this, I was asked for the ToDoist token. I removed the action (using the “-” in the manage apps). When I reinstalled from the Directory, I did not get that request for the Token.

Thanks again for any help. My next attempt is going to be to delete (again) and then add by copying the script from the directory and treating it as a new action entirely.

Edited to add: I reinstalled, got the things step tried (a) to comment it out in the manage actions section and (b) to remove.

:mw

Could you share your script/action? Very difficult to speculate without specific examples.

Have you read the Todoist integration guide? It’s probably the best place to understand the options available. I think the “Tasks in Todoist” example in that guide is probably the best place to start - you would just need to add some logic to identify and route the different custom markup you are using when looping over lines.

Of course. I should have been clearer. It is the process meeting notes action from the Directory.

;mw