Move to Obsidian with no space


I’m trying to move all my note from Draft to obsidian as I use Draft only as capture tool.

I’m using kind of an update version of this action : Move to obsidian

It works well most of the time (seems to doesn’t work when the first line is a url or have special characters in it…)

But the problem is that the very first line of the note in obsidian is empty.

The content is only paste on the 2nd line.

And it’s kind of an issue because the note doesn’t trigger the Obsidian metadata correctly (screenshot below as it should be)

Is there a way to paste the content of Draft note directly on line 1 of obsidian note?


I just did a little testing of this action, and it is not sending the extra line in the text parameters used. It appears to be something being added by the advanced-uri plugin at Obsidian’s end…so you would need to contact the creator of that plugin to see if there’s a way to avoid that happening. I didn’t see anything obvious in their docs.

There are other ways to send data to Obsidian, however. You might want to look at some of the other options in the Obsidian integration guide. If you are writing directly to files in the vault, rather than using URLs, that would not be a problem.

1 Like

Thanks for taking the time to answer :slight_smile:

It have tested this action and it works well now : Save in Obsidian Vault | Drafts Directory

Except that the action failed if the file name already exist (instead of append the new content on the existing file in the vault)

Do you know any tips to solve this issue?

That action has a single “File” action step. That step has a “Write Type” option, which is set to “create”. If you edit the action (tap and hold on it in list > Edit on iOS), tap on the steps, then the “File” step, change it’s write type to “append”.

Append actions will create the file if it doesn’t exist, or add to it if it does.

1 Like

It works great now, thanks a lot for your help :grinning:

1 Like