Markdown and line breaks


#1

I am a Markdown amateur. I have created several notes in drafts using Markdown which I then send via email. When I send the email I lose all line breaks and the entire note is one paragraph. What am I doing wrong and how do I get this to work with the line breaks?


#2

It’s a little bit hard to tell exacly what your issue is wthout seeing the text, but maybe ths couple of tips will help?

  1. If you want separate paragraphs, leave a blank line between them.
  2. If you just want a line break (and are not using bullets, etc.), then add two spaces at the end of the line.

You may also want to check out John Gruber’s original Markdown syntax guide.

Other subsequent flavours of Markdown may allow other syntax for this sort of stuff too (e.g. backslashes).


#3

GitHub Flavored Markdown maintains line breaks. It’s in the Markdown Options section of Drafts’ Settings.

I’m not a big fan of GitHub Flavored, but it can be helpful for this, especially if you have iOS set to add a period whenever you type two consecutive spaces.


#4

Thanks so much. That change worked for me and is easier than the two spaces.


#5

Just make sure you are always converting to HTML before exporting, or copying the Markdown directly to somewhere set to receive GFM format; otherwise you’ll be in exactly the same position as before.


#6

I’ve avoided Git-flavoured as it seems less portable than vanilla Markdown or even MultiMarkdown.

I have code that parses (a subset of) Multimarkdown and some of the Git-flavoured extensions might make semantic sense - but I’ve avoided them.

Having said that, I’m taking (basic) Taskpaper as well as contemplating (a subset of) CriticMarkup.