Mac Drafts Not Appearing in Menu Bar on Launch

Hi. I have Mac Drafts set to launch at startup, with the main window closed on the assumption that I can quickly access the app through the menu bar widget. However, though Drafts does successfully launch with the main window hidden., the menu bar item doesn’t appear, nor does my Quick Capture keyboard command work. When I open the main window, the functionality of both is restored.
Am I doing something wrong?
Thanks.

Interesting. I can’t reproduce here. Configuration like this?

Any difference if you turn off and back on the “Launch at login” option?

If you quit and relaunch the app after login, does the menu bar appear properly?

Yes, the prefs are set as shown above, but toggling Launch at login is kinda hard to do, since I have to restart to test the problem. But I captured a screen grab after rebooting.

I have what I think is the same issue. The way it ‘bothers’ (it’s not the end of the world as I don’t reboot that often) is that the quick capture shortcut doesn’t do anything until after I’ve first ‘launched’ Drafts (even though I Drafts IS running).

After reading this post I noticed that the menu bar item wasn’t shown. Having toggled the ‘show in menu bar’ setting and restarted it does now appear.

But still the quick capture doesn’t work until Drafts is ‘run’ for the first time.

AN EXAMPLE:

  • Restart Mac OS
  • See Drafts menu bar item and a ‘dot’ under the app in the dock
  • Press keyboard shortcut for Quick Capture
  • [nothing happens]
  • Click Drafts in the dock
  • Quick Capture window launches
  • From now on things work as expexted

I may have solved my problem which I described in my last post. This may or may not be related to the initial post. I’ll describe it in case it’s of use to anyone!

I had Drafts set to be launched at startup both in the Drafts settings and in the User System Preferences. I removed this option from the System Preferences, leaving ‘Launch at Login’ set just within Drafts itself.

It all now functions as I’d expect.

2 Likes

@robbyberman Does @_Dan suggestion work for you? Did you also have it configured in both places?

Alas, Drafts isn’t in my Login Items list — I just looked — so that’s not the issue for me.

Actually - In my hast to quickly check and respond while trying to do other things, I think I was mistaken in saying that I’ve resolved the problem.

I’ve just shut-down and started up again (rather than re-starting) and, with start Drafts at log-in set just in the app, when my Mac boots up the dock shows a dot under Drafts but the Quick Capture shortcut doesn’t do anything and Drafts doesn’t appear in the app switching list (cmd+tab) - until that is, I ‘open’ a Drafts windows by clicking the app in the dock (or using the keyboard).

Tried on three different Macs and can’t reproduce this problem. Weirdness. Wonder if it’s a conflict with some other menu bar / startup item. Do you two run Bartender or any similar menu bar utilities?

Nope, no menu bar utilities, but lots of menu-bar items as that screenshot showed. Also, I’m wondering if this is fundamentally a menu bar issue, since Quick Capture also doesn’t work for us.
In your tests, agiletortoise — just checking — you are restarting, right?

Okay. New info. I just created a default user for testing. Set up Drafts to do its thing, and restarted. It worked as it should: menu bar and Quick Capture both fine. So it is a conflict with something.
Does this mean anything to you? System log after reboot:
“Apr 17 12:30:01 HQ com.apple.xpc.launchd[1] (com.apple.xpc.launchd.user.domain.503.100092.Aqua): Could not import service from caller: caller = otherbsd.2121, service = com.agiletortoise.Drafts-OSX-Launcher, error = 119: Service is disabled”

OK, I’ve been doing menu bar elimination rounds, with some inconsistent results, maddeningly. I currently believe that there’s a conflict between Drafts and Cardhop. Sometimes when Cardhop is running at startup, I see the Drafts menu but Quick Capture doesn’t work. Other times, neither works. Can you try this, and/or contact them?
Also Hemingboard, I think. I’m going insane here.

OK, 2 days later. I don’t know what to think. Some days the menu bar and Quick Capture are available after boot up, and some days — like today — they’re not. Lost.
Is there no way to capture what’s going on in a log?

My summary is the same: some times it’s fine, other times Quick Capture only works after Drafts has been made active. I only have a few menu bar items: Citrix, Fantastical, 1Password and Magnet. The issue seems the same even with these disabled.

Might be a timing issue at login. A couple troubleshooting ideas/questions:

  • If you turn off “launch at login” in Drafts, and manually launch the app - does the menubar icon always appear properly?
  • If you turn off “launch at login” in Drafts, and add Drafts to your login items in System Preferences manually, is the behavior any different?

For me, it doesn’t matter which of the two ‘launch at login’ options are used. With both options, quick capture doesn’t work (doesn’t show the window) when the keyboard shortcut is used to access it until after the Drafts app itself is ‘launched’ - either by clicking the dock icon or with the keyboard.

N.B. It could be relevant that if I take the following steps, clicking the Drafts icon in the dock doesn’t show the Drafts main window but instead shows the Quick Capture Window:

  • turn on the Mac and log in
  • Press Quick Capture keyboard combo (nothing shows)
  • Click the Drafts app in the dock (the Quick Capture window is displayed)

Another idea I’m testing now.
The last two mornings, the menu bar item and Quick Capture didn’t start at login, and when I manually opened the Drafts UI, the menu bar item popped in, followed quickly by the Location Services icon both times. Hm. I’ve disabled Drafts’ permission to use Location Services, and we’ll see what happens tomorrow. I’ll report back.

For me, the problem still occurs with Location Services disabled for Drafts.

The problem didn’t occur this morning with Location Services disabled for Drafts. I’ll keep testing this since Dan and I have both been seeing intermittency in our experiments.

Day 2. Nope, no good. Even with Location Services off, the Drafts menu item and Quick Capture didn’t launch at boot up today.