Issue archiving a draft using a Shortcut

Hello, I’ve created a shortcut to move what I dictate with my Apple Watch with Drafts app to Things 3 if it has a particular hashtag (#Things). It’s working good but the last step of the process is to run a Drafts Actions to Archive the selected Draft but it’s not working.

I’ve created a 30 seconds video where you can see what I’m doing:

Even you can see in the video the Drafts message: Moved to Archive but my Archive is still empty.

I’ve used the Archive actions and also I’ve downloaded the [](Archive Draft) action with the same result.

What is the after success setting for your Things action? I’m wondering if the Shortcuts call to the archive action you linked to could be undoing any archiving on your Things action. I would have expected you only need to set the after success to archive on the Things action and that would be sufficient.

Thanks for your answer. Actually I deleted the last step to see if anything is archiving first and the last action is undoing it but the result was the same.

This is a screenshot of my shortcut before delete the last step: Screenshot

Okay, that does not sound like it is having a reversal effect then. But, could you try setting the Things action to archive on success and run the shortcut without the archive action?

I ran an experiment with this shortcut and this action, and the it successfully updated and archived the first draft in my listing from Shortcuts.

Based on this, ff archive on success doesn’t work, then that would suggest you are not getting a successful end to your Things action.

It’s weird. I’ve followed all your suggestions and it is still with the same issue.


  1. Do the examples I posted above work for you?
  2. Can you share (not screenshot) the Drafts action you are using for Things?
    • I don’t use Things myself, but I might be able to spot what’s going on, and there are definitely other people on the forum who are big Things users.
  1. The actions works, the shortcut only goes to draft.
  2. The action I use is: Things

Okay, so it is something specific to the action.

Not sure if this will make any difference, but try this amended version. I’ve reworked the callback URL to use the documented format for Things and also encoded the static part of the back link to Drafts. The action is set to archive on success, but do double check that this setting is retained after import.

Unfortunately is happening the same with your Things alt. than with my example. It’s writing to Things 3 but it’s not moving anything to Archive. Even my Archive is empty.

I use OmniFocus. I’ve substituted in its, quite similar, URL scheme for Things’ as follows.


This worked perfectly. It created a new task in OmniFocus, and on returning to Drafts, the draft was moved from the inbox to the archive.

I’m sorry, but at this point, there’s nothing more I can test without paying out to become a Things user; which I’m simply not in a position to do.

Hopefully, someone else on the forum who uses Things can dig into the use of the Things x-callback a little more for you.

Thanks for your help. Probably is an issue with any of the apps.

Hard to say exactly what is going on here without having the exact Drafts actions and shortcut you are using to test with. Maybe some sort of timing issue.

I would suggest this approach could be better achieved a few different ways.

First, by not calling two Drafts actions. Just set the after success setting of your Things action to archive the draft for you.

Or, do it from Shortcuts. The “File Draft” shortcut action can set the draft to be in the archive without needing to open Drafts or have any special actions installed. This would be more reliable and faster.

Hello, thanks for your answer.

Actually I’ve modified my shortcut and the drafts action following the advices given in this post.