iCloud sync error message on iPhone


#1

Hi All.
I have installed the Drafts 5 app on both my iPad & iPhone.On my iPhone when I try to turn on iCloud sync it says, “iCloud not available. Check that you have an active iCloud account and Drafts has been allowed permissions to use iCloud”
When I installed on my iPad, iCloud sync was automatically turned on. Why is this an issues on my iPhone. I have tried uninstall and reinstall and reboot several times to no avail. Help please.
TIA.


#2

That means, for whatever reason, iOS is telling Drafts there is not an iCloud account, or it is not allowed to use that iCloud account. A couple of things could cause this to happen, I suggest checking:

  • Go to iOS Settings, tap on your account at the top, just double check everything looks good - it’s not asking for a password, you can tap on “iCloud” and see your storage settings, etc.
  • Tap on “iCloud”, scroll down. Drafts should appear in the list of app and the switch should be turned on to allow Drafts to use iCloud.
  • If those look good, reboot the device, return to Drafts Settings > iCloud Sync and see if it will let you enable it.

If that does not help…

  • Do other apps which use iCloud all sync properly between these two devices?
  • Is this a work issued phone? Some corporate IT departments apply iCloud policies which restrict access to third party apps.

#3

Thanks for suggestions. By turning iPhone off and charging it over night seemed to fix it!