I can’t add an action

I wanted to start over with a clean slate in Drafts. I deleted all my notes, I deleted all my actions, I deleted all the action groups. Now I cannot create a new action and I cannot import a new action. Pressing the “+” button at the bottom of the actions list does nothing. I tried importing an action from the directory and all I get is a select a group to import the action into and a cancel button. Because I deleted all the groups, I cannot choose a group.

I restarted my iPad, no change.
I deleted the app and reinstalled. No change.
I deleted the all, did a normal shut down and restart of the iPad, reinstalled, no change.
I deleted the app, did a force restart (volume up quick press, volume down quick press, press and hold sleep/wake button), reinstall Drafts, no change.
Behavior replicated on my iPhone.

I’d appreciate any thoughts on how to resolve the situation. Thanks.

You have to have at least one action group to hold your actions. Create one, then you will able to create actions.

I’ll do some testing in the scenario. The app should certainly handle that case with a more helpful message.

1 Like

Solved my own issue…

I had to press or long press where the action group name usually is and I was able to create a new action group. From there I can create a new action in that action group and I was able to import an action from the directory.

Even though I solved the issue before seeing a reply, I think I gained some benefit from this thread and writing out the issue. Thanks all for being there with moral support.


1 Like

You may find you want to reinstall some of the default action groups. You can find links to them here.

A lot of common editor functionality is implemented in those actions, which you may miss.

1 Like