How to Disable Spelling and Grammar Check


#1

Greetings, Drafts Community. I really enjoy using Drafts on both macOS and iOS.

I’ve opened an account here as I’m trying to figure out how to disable the spelling and grammar check. I seem to be able to disable (untick) it for one draft, but when I start a new draft the checks are all ticked again. Is there a way to turn it off for all drafts?

Thanks, Drafts. And thanks in advance, Drafts Community.


#2

Are you making any changes to the Syntax highlighting option? Editor settings in the “Aa” view are store per-syntax (e.g. you might want spell-checking ON for Markdown, but OFF or Javascript).

Not currently aware of any bugs with those settings not getting stored, but it’s certainly possible there are in the beta.


#3

Thank you for solving the problem.

I’m embarrassed to say, I wasn’t changing the setting in the ‘Aa’ view as I hadn’t seen it – I was going into ‘Spelling and Grammar’ in the ‘Edit’ menu. Now, of course, once I change the settings in the ‘Aa’ view, they persist.

This is a video showing what I was doing wrong:

And once I found the ‘Aa’ view that behaviour makes complete sense.

Thanks once again.


#4

Got it, thanks. Definite bug.


#5

Thank you for producing such a fantastic app.