Gonna feel like an idiot - Insert Text on MAC

I have a simple three step action which runs great on IOS but fails on Mac.

Insert Text: [[
Script: Insert Date
Insert Text: ]]

When I execute this on IOS, no issue, runs great. When I run only the insert date step on Mac, no issue, runs great. When I run the full action on Mac, I get a fail “Insert Text Not Allowed” error. If I change from the [[ to anything else like foo, it works fine. For some reason is it not allowed to do insert text with [[ on a Mac?

Could you share the action as you have it configured? (You can share to action directory as unlisted and send the link)

Hard to troubleshoot without seeing what’s happening.

Here it is

That outputted fine for me on Mac and iOS. But I think what you actually want to do could be produced by a single Insert Text action containing [[[[date|%Y-%m-%d]]]].

Interesting, even changing to that, with a single Insert Text I have the same error on Mac:

Screen Shot 2021-04-15 at 12.31.08 PM

On IOS it continues to work without fail.

That screenshot doesn’t seem to match the action does it?

Can you share more details of the action, the version of Drafts you are using, and confirm if you can insertsome basic text and if you can insert a Drafts tag without formatting (for example, just the date).