Getting "Error 405, Method not Allowed" posting to WP

I’ve been using the stock “Post to Wordpress” action for months and it’s worked fine. Today I’m getting:

HTTP Error: 405, method not allowed
WordPress posting failed

From the Mac and iOS.

I’ve got a self-hosted WP site on WP 5.8

Any ideas?

  1. Is it occurring for any draft you are trying to post, or just one specific one?
    • Maybe there is something about a draft you are trying to post that’s affecting things?
  2. Assuming you have not updated anything and it is not you, has your web host changed anything recently?
    • Web hosts can sometimes make broad changes that mess up your instances.
  3. Have you checked in your WordPress log for additional details about the error?
    • The log might have extra info in it to track down the issue. Best to trigger the error and check the log straight away as I think the WordPress log is pretty verbose when your site gets a lot of use; though it has also been a very long time since I touched WordPress, so that may be better filtered as standard now.

Most likely the WordPress XML-RPC interface (“Remote Publishing”) is disabled for your blog. Check your WordPress settings to make sure it is enabled.

If it is, and it’s still giving a 405, it’s likely your host blocks XML-RPC for security reasons. Many, especially shared, hosts do this, but will enable it for you if you request it specifically via support.

XML-RPC is turned on by default since WP 3.5

I reached out to WP Engine, they say it’s turned on with no rules that should prevent it.

It fails with any file, not just one.

The host looked through the logs and it can see Drafts trying to post. The WP install matches the checksum of the source code. ¯_(ツ)_/¯

We also tried with plug-ins disabled. No dice.

Something must have changed server-side, as nothing has changed in Drafts.

It’s not specific to a certain draft, is it? Possible encoding disagreement with a special character or such is possible, but that would be specific to a certain text. That’s the only other thing I can think of.