Evernote Actions

In Evernote I have a Notebook called “Things Needing Attention” and a note in it called “ToDos”
In the action I have Note “ToDos”. and Notebook “Things Needing Attention” (no quotes in either). Everytime I run the action I get an error message. What am I doing wrong?


What’s the error message you get?

What shows in the log (see show action log)?

Notebook Not Found

Many thanks


Try retyping the notebook name or copying and pasting it from Evernote. Perhaps you have an extra space, non-breaking space or an accidental unicode character that looks the same but isn’t.

You may also wish to check against other notebook names. Ideally both with and without spaces. This should give you a broader insight.

Failing the above, remove your Evernote credentials from Drafts, run the action again and reauthorise. There’s always a chance it could have gone wonky.

Sorry no good. None of these made any difference


  1. Notebook name for originally specified notebook was definitely a character for character match.
  2. No other notebook names work either.
  3. Clearing Evernote credentials and retrying made no difference.

Next step would be to leave the notebook blank. As per the Evernote action step documentation attempt to put the new note into the default workbook.

See if you get a note doing that or a different error message/log entry. You are not specifying a notebook name so there’s no feasible way you should get the same result. Something has to change and that will hopefully give us an additional clue as to what is going on.

Re Draft’s error sending to Evernote:

I have set up a new notebook called Things Needing Attention. In the Draft’s action I have selected Action Required as the note and Things Needing Attention as the notebook Text and Prepend, but still get the same error message.

I attached three screen shots. As you can see the notebook is set as Things Needing Attention When you look at the error the Notebook shows Inbox, which doesn’t exist and Notebook Not Found.

Many thanks


Any reason not to try my last suggestion then?

Sorry forgot to say.
Notebook was character match
No other notebook name work
Cleared Evernote and logged in again

Latest try. Named action Test. Left Note and Notebook blank. Text and create.

Error result. Running. iPhone 10xs 12.3.1. Evernote 7.11. Drafts Pro Latest version.

My suggestion was…

Your action was…

So going back to my suggestion, what happens if you just leave the notebook blank?

Note that the note name is mandatory and when you left it blank you received exactly the expected error for doing so.

Sorted. All my fault. When I checked the notebook name I finally discovered that ios had automatically added a space at the end.



1 Like

Glad you got it sorted