Error creating Titles in Actions to create new notes

Does anyone know why an ACTION I’ve been using since Drafts 4 does not correctly format the [[TITLE]] during the creation of a new Evernote Note? Greg informed us that we might lose Evernote in the future. Is there a TRICK I can use to fix this specific issue?

Here’s what it looks like in DRAFTS4:

Called NAME from COMPANY about REASON at 1040 hrs, 2024-03-10

Here is what it looks like in the current Drafts version 43. (423) :

CalledNAMEfromCOMPANYaboutREASONat1040hrs,2024-03-10

Question: What is causing the removal of spaces between text?

I think the most likely reason is Evernote changed something again.

My second recommendation would be to switch to emailing from Drafts to Evernote to avoid using the API.

My first recommendation would be to stop using Evernote. I regretfully say this as someone who used it for a decade or moreand advocated for the product for muchnof that time. However, things have changed dramatically and almost entirely worsened for customers. Alternatives are available - which is why so many have moved to other products.

Thank you for the assist! I hadn’t thought of the email approach, though I’ve been emailing from outlook to EN for years…totally spaced it.

I have been stalling to make the transition just because it worked so well (drafts, Emails, docs into EN etc…) in my workflow. Exploring obsidian since I store mostly text now.

I think my Transition out of Enote requires:

Step one. Solve the issue you just helped with.
Step Two. Create a IOS Shortcut that replaces Textexpander Fill-in Snippet since they don’t work in DraftsPro to log calls throughout the day (I use Fill-ins a ton)

That would stabilize my workflow transition into DraftsPro.

Step Three. Start the transition from Evernote to Obsidian by pointing my note DraftsActions from Enote to Obsidian.

Step Four. Import 15,000 ENotes into Obsidian

Step Six. Sunset my subscription to enotes.

More commentary than needed. Sharing in case you see a solution to my other transition pain points that I don’t. REALLY APPRECIATE your recommendation to use Email instead of the API. Thanks again!

This is an Evernote bug I’ve seen before in the past. You might try forgetting your Evernote credentials in Drafts settings and re-authenticating. I might be wrong, but I kind of feel like this fixed it for someone in the past.

:rage:! That worked! thanks for the tip in! I’m still taking Sylumer’s advice recommendation to transition away from evernote, but this helps till I get there.