Editor Preferences: Unable to select Typeface

When I select the Font icon at the bottom of the screen to open Editor Preferences/Markdown, I select the Font dropdown menu and choose Other, I am presented with the Fonts window. From here I can select a type family (Calibri) however when I select Light or Bold from the Typeface column, the font remains Calibri Regular.

That is expected behavior. Only font family can be selected, because weights and styles from that family are applied during syntax highlighting.

The Mac font panel shows all those options even if they are not available to select…there no way to override that.

Interesting. Thanks for the info. So how would I go about selecting my favorite Calibri Light using syntax highlighting?