Drafts will not "Open at Login"

I cannot get Drafts to “Open at Login.” In fact, I can’t even add it to the Login Items in Settings. In addition, I HAVE set the Drafts preferences to “Launch at login” but it will not do so.

I have deleted and reinstalled Drafts but that has not solved the problem.

Anyone else experiencing this issue? If so, have you found a solution?

Are you running the App Store version? I’ve found login items don’t work right with TestFlight beta builds, often.

Yes, from the Apple Store, v 38.0.1. I have the latest OS on an M1 MBP.

What does Drafts look like in System Settings > General > Login Items? I’ve seen a few cases (mostly with TestFlight builds) that the “open at login” feature registers the app, but there’s something corrupt about it. It doesn’t launch, and shows as a generic icon in the background processes section, not as the app icon.

When that happens, adding it to Login Items also does not throw an error, but the app doesn’t appear in the list and doesn’t launch.

I don’t know a sure way to fix this…it’s something awry at the macOS level. Next thing I’d try would be:

  • Move Drafts to the Trash.
  • Reboot
  • Check that it no longer appears in System Settings > General > Login Items
  • Re-install and launch Drafts.
  • Return to System Settings, and try to add it to Login items again (don’t try the “open at Login” option in Drafts)

Thank you for the tips. I followed the steps you outlined. Drafts is now launching at login. I still cannot add Drafts to Open at Login, but that is ok so long as it launches at login.

Thanks for the help.