Drafts on WatchOS 7.0 not working correctly

I am a brand new user and just downloaded Drafts on my iPhone, Mac and Apple Watch, all of which I recently updated to the new OSes. It syncs fine between my iPhone and Mac, but my Apple Watch isn’t syncing at all.

Furthermore, when I try to archive or delete drafts in my Apple Watch inbox, I get a tap on my wrist but nothing happens. The drafts stay there.

Is this a known issue with WatchOS 7.0?


No known issues with watchOS 7. Sounds like the connection between the phone and watch has gotten stuck, somehow. This is pretty rare, but happens now and then, particularly with new installations.

Steps to try:

  • Power cycle both watch and phone.
  • Launch Drafts on phone, and then leave the app. This will force it to attempt to push current inbox data to the watch.
  • Launch Drafts on the watch - does the new date appear?

If not, the next thing to try is to remove the app from the watch and reinstall it using the Watch app on the phone, then repeat the initial steps (probably not he power cycle, but the other ones)

1 Like

That worked, but it took a while to get it right. In your 2nd step, I had to actually create a draft on my phone before leaving the app. Just bringing up the app and leaving it didn’t do anything.

Thank you for your help!

1 Like

I had the same problem today and power cycling both worked like a charm.