Drafts iOS not creating new draft after set time

Hi, I’m using drafts pro 28.1 on my iPad Pro 2018 (iOS 15.0.2) with a setting to create a new draft after 5 minutes. When I come back to the app (well after 5 minutes have passed and not in focus mode) the previous draft is still open. Is this a bug or am I not setting this up correctly?

There are two features that affect whether new drafts are created when returning to the app:

  • The “New Draft After” setting, which determines the time you are away from Drafts before it should create a new draft.

  • Focus Mode, which can be enabled in the editor (eyeball icon below editor).

Focus mode temporarily disables the “New Draft After” timeout for the current session, to allow you to lock the current draft at a time you plan to work on it for longer.

Details in the User Guide: Focus Mode - Drafts User Guide

Is it possible you enabled Focus Mode?

1 Like

I have the same problem. And yes, I am pretty sure, that I have not pinned a note. Or is there still a distinct focus mode? Because I assumed, that the „old“ focus made had been replaced by the new „pinning“ function. I have already reinstalled the app, but it didn‘t change anything. This is really sad, because this is one of the best features of this awesome app. Does anyone have some other ideas?

Or is this „new draft after n seconds“ a Pro feature?

Thanks a lot in advance!
Kind regards
Stefan

This is not a pro feature, nor are there any known issues with new draft creation. Could you describe what you are seeing in more detail?

Pinning did replace focus mode, but same applies. Is the pin at the bottom left of the editor enabled (filled in) or not (outlined)?

What is your “new draft after” timer set to? Have you tried different values?

When you are testing this feature, have you left the app (it is off screen) for longer than you have the timeout set for and then returned?

Thanks a lot for your quick reply. To answer your questions:

  • The pin is outlined
  • I have tried several settings, usually I have it set to 30 seconds.
  • Yes, I have left the app for longer than the set time.
    I have an iPhone 11 Pro, iOS version 15.5. Language set to German.
    Could it be that there are somewhere some settings remaining and now conflicting with the new installment? Because I have been a user of Drafts for quite some time (pre 5) and only came back yesterday to give it another try.

Is there anything atypical about the way you are launching Drafts? Just tapping on the home screen icon? I can’t think of any other settings that could defeat this feature accidentally.

No, really simple tapping on the home screen.
Anyway. Is there a way I can completely reset my account? Because when I delete all apps on all devices and I even delete the “Drafts” folder on iCloud drive (on all devices), my archived notes reappear, when I reinstall the app. I have saved all of them in the meantime. So I want to try and do a complete reset of my account. If that is possible.

Update 2022-05-20 17:27 GMT+1
I just updated to 32.1 and all of the sudden it works (tested only on my iPhone so far). I am not trying to be funny here. Did you fix some related bug in this version or did the reinstall itself the trick? I don‘t know. Thanks for your support! I will test it now on my iPad and iMac too.