Drafts 35.0.2 respects some line endings but not others in Mail via Share

I have a number of notes that I use as email templates. Drafts has always worked great for this:

  • Select a note
  • Choose Mail from the Share menu

In the latest version of Drafts, the formatting in the email ends up wrong, but in a way that I can’t make sense of. Some hard returns are respected while other aren’t. I’ve tried reformatting and pasting, with the same results (but different formatting!)–the formatting looks correct in Drafts, but in Mail, the formatting is wrong.

Do you use markdown?

If you’re talking about line breaks / new line characters markdown requires two new lines to also display them in the resulting text. Maybe that’s one of your issues?

Alternatively you can add two spaces and then a new linr to force a linebreak.

Just my two cents. For more details you Nichtverantwortung to share some examples :slight_smile:

I can’t reproduce any problem. If you are selected “Mail” from the share menu, I assume you are doing this on Mac? In that case, Drafts is just handing on text to the share menu, and it’s up to Mail do decide what to do with it - but, again, I can’t reproduce any problems with line feeds.

Do you have an example text that demonstrates the problem?

Could you confirm version of OS/Drafts?

If you use the “Mail” action in Drafts rather than the Share menu, any difference?