Drafts 33 broke my shortcuts on iOS [iOS 16.1 update fixes]

I have a number of shortcuts that append to a draft based on the UUID. They all broke with the latest update. It either prompts me for the draft to which the data should be appended, or it fails with an errors saying "There was a problem running the shortcut.

I can fix the shortcuts on the Mac but they are still not working on iOS. I can’t seem to fix them on iOS. Still exploring.

Anyone else?

1 Like

We are in a weird time for Shortcuts, as iOS 16/iPadOS 16/macOS 13 complete change the way shortcuts are implemented by third party apps - but Apple has not shipped all those OSes, so you can’t be on all the same code cross-platform.

We tried to maintain compatibility as much as possible, but there are some places where Shortcuts behavior changed, as well, so some weird bits.

Also completely possible it’s a bug in our new implementation.

Could you share the actual shortcut as you have it configured? Much easy to test and comment on possible fixes.

Here’s a link to one of them. It gets the UUID from a Data Jar entry. You’ll have to manually enter a valid UUID to test it.


It works on the Mac. It doesn’t grab the Draft on iOS, instead prompting me to select a draft.

This only change I made to this Shortcut was to replace the UUID value with a hard-coded string, and I am able to use it on iOS 16, iPadOS 15, and Mac without error.

Are you sure you are getting a valid UUID value back from DataJar in your version on all platforms?

(Also, please clarify, what versions of the operating system are you running on your different devices?)

Interesting. If I hard code the UUID I have the same problem: it works fine on the Mac (as it did with the Data Jar variable). The Shortcut runs but rather than opening the draft with the given UUID, it prompts me to select from a list of Drafts (see screen shot).

I am running running Monterey 12.6 on the Mac and iOS 16.0 on the phone.

I have a couple simple shortcuts that gather some inputs, create a new Draft then open that Draft. Unsure if v16 or a Drafts update broke this, but these no longer work. Doesn’t appear I can feed the resultant created Draft to Open. I get the same “pick a draft” list.

I’m running Drafts v33.1 on iPhone (iOS 16.0) and on iPad (iPadOS 15.6.1).

If I run the following shortcut on the iPhone I am prompted to select a draft twice. If I run it on the iPad, I am (correctly) prompted to select a draft once.


FWIW, and I know this isn’t comparing apples to apples, more apples to oranges, but I created the equivalent shortcut for doing the same thing with Bear.


This one only prompts once on the iPhone. Based on that result, I don’t think it is a broad shortcuts bug with any lists being passed around, but something tied to what Drafts is passing in - but something that also seems to be tied to something about the new OS too.

iOS 16 / macOS 12 introduce an entirely new way to implement Shortcuts for apps. This definitely means there are and will be weirdnesses between implementations which have been updated for this new method when running on iOS 16 / macOS 13 and those same apps running on iOS 15 / macOS 12.

Bear has not been updated, so is running on the “old” method on both platforms.

Some of these differences are Apple’s bugs/changes, some may be things Drafts needs to tweak. Trying to keep up with all those and resolve those that I can - but in this specific case, it seems to be an Apple issue in the new frameworks not properly passing values between actions. Obviously, this will all get better when you can have all your devices running on the “new” stuff once iPad/Mac updates are released as well.

I just did some more testing on this today. This seems to be specific to iOS 16.0. The result variable is not getting set properly from the next step. The exact same Shortcut works in both iOS 15.x and iOS 16.1 without prompting for the draft. Will probably just have to wait this bug out until iOS 16.1 is released.


Good catch.

I jumped to conclusions when I created the title for this post, assuming it was related to Drafts 33 rather than iOS 16 (which came out at the same time).

Is it okay to rename posts on this forum?

I am happy to report that iOS 16.1 seemed to have solved all of the anomalous behavior between shortcuts and Drafts. Everything is working again!


Good to hear a confirmation!