Disappearing Draft

Hi there,

I’ve been using Drafts to write out book notes before transferring them into Obsidian, which has worked well until this morning.

The note for the book that I’m currently reading has disappeared. I’ve tried searching for it in Archive, across work spaces and a cross all Drafts and it can’t be found.

I’m not sure what could have happened to it, but given that I was coming to the end of the book I’m really keen to get it back. Is there anything I can do around a history, or restoring it somehow?!

Thanks a lot for your help. It’s really appreciated!

It should not have just disappeared.

  1. Make sure you have all filters disabled when you search.
  1. Do explicitly check the trash folder when you search.
  1. If searching the usual way is not working, give Quick Search a try, just in case.
  1. Check your recent drafts for any you do not recall creating. Maybe you did an accidental overtype of all of the content. You can look at version history of particular drafts to restore it.
  1. Assuming you had backups enabled, check those to restore a draft, but unless you deleted the draft >30 days ago, or explicitly dumped it from your trash, this should not be necessary.

Hope that helps.

1 Like

Thanks @sylumer - I really appreciate your time putting that together.

I still don’t know what happened to the Draft, but I’ve had to restore it from a back up at the beginning of the month. 90% of it is back, so I’ll go from there.

Thanks again for this, I’ve learned a lot today!

1 Like