Dictation for watch not working... sometimes

Hi. This is a problem driving me crazy and I’m mostly just hoping that somebody will have an idea I haven’t thought of.

When I’m out walking the dogs, I will try to quickly dictate a note into Drafts on my watch and, inevitably, the dictation doesn’t work. A message will come back that dictation isn’t available, and I’ll have to revert to scribble mode (or, more likely, pulling my phone from my pocket to access Drafts there).

My problem is that I can’t replicate this error under any other circumstances. Dictation works perfectly at home. It works perfectly when I put my watch into Dog Walking focus (at home). It works perfectly when I have AirPods in and am playing a podcast. It works perfectly when I’m being logged as doing a walking exercise. It works perfectly if I turn wifi off to simulate being outside the range of my home wifi. I can simulate everything I can think of that’s in the environment when I’m walking the dogs and dictation on Drafts on my Apple watch will work. But as soon as I leave the house and do the actual walking, it doesn’t.

If anybody can think of anything obvious that I’m missing, I’d love to hear it. Because at the moment, I’m going crazy trying to solve it (and not having any idea what to search for because it’s such a specific, weird problem).

Thanks in advance for any help.

We might need more details to help, like Watch model, watchOS version, and breed of dog. :grin:

Heh. Apple Watch series 5, watchOS 9.3.1, a toy poodle and a shih tzu-poodle cross.


More seriously, there’s a number of conditions that could be playing into this…are you dictating in English? I assume this Watch does not have a cellular connection, but are you bringing your iPhone with you when going on the walk?

A lot of what goes on in system dictation is a black box. In theory, modern watches and phones support on-device dictation, but it’s not for all languages, and requires local data that, to my understand, is not part of the OS, but downloaded by the system as needed, and there’s cases it won’t use it for :man_shrugging: reasons.

If you are simulating at home, are you also turning off Bluetooth? Because the watch will prefer to use the phone via Bluetooth (for power reasons), and could still be passing data to the phone to process even if WiFi is off.

I might try resetting/restore the Watch as a next step. That might force it to re-download the dictionaries it needs to process on-device.

Thanks for the insight on the black boxiness of the dictation. Yes, I’m dictating in English. No cellular connection, but the iPhone is always with me on a walk. I’m pretty sure I tried it with Bluetooth off at home, but I’ll try it again now. I’m also literally just about to head out on a walk so I’ll pay closer attention to the actual error message this time.

(Update: yes, I just tried it and it works with both Bluetooth and Wifi off when I’m at home. Which suggests everything on-device is fine, I guess.)

And if all else fails, I’ll reset the whole thing. Thanks again for the tips - if nothing else, it’s reassuring to know that I’m not just missing something incredibly dumb and obvious. (Although if it turns out I am, that’s okay, too - I’d just like it to work, even if it means briefly feeling stupid.)

1 Like

I think most of the dumb and obvious things would make it never work, not just fail on your walk - if that’s any solace.

Thanks. I just did some more testing while out on the walk. Stupidly, I hadn’t tested any other apps (I don’t tend to use any other apps when I walk), but when I tried it on Messages, I got the same problem. So it’s not a Drafts thing, it’s definitely an Apple thing.

I also narrowed it down to something to do with my AirPods. If I took them out and they disconnected from bluetooth to my phone, dictation would start working again. It would also stay working for a short period of time when I put the AirPods back in before eventually stopping again.

Anyway, as this is not a specific Drafts problem, I shall take my issue over to an Apple forum somewhere. (But if I find a solution, I’ll come back and post it here to hopefully save somebody else the hassle in the future.)

Thank you again for your help.

1 Like

Belated update for this. I was never able to get the dictation to work while listening to podcasts on my phone. Something to do with the AirPods not switching properly away from the phone to the watch and getting confused with which device I was talking to (I think).

Anyway, my hack is that while I’m out on the walk I listen to podcasts through my watch (my podcast app, Overcast, syncs from phone to watch). That works without a problem. I get a thought, tap on Drafts, take a verbal note, and as soon as I end it, it saves to Drafts and my podast resumes automatically. Perfect. (Well, not perfect. It’d still be better if Apple made it smart enough to work while listening via my bigger-batteried phone. But good enough.)

Not related to Drafts or even the iWatch, but have you heard about the Snip’d app? It’s one of the best podcast apps I’ve found for jotting down podcast notes on the go.

1 Like

I have the same intermittent issue as well, but not using my Apple Watch, rather if I am in the car & want to use dictation ‘create draft using dictation’ it will sporadically not work/fail or take a crazy long time to transcribe only to get most of the text incorrect.

I use a bluetooth connection to my car stereo (not apple car play) and had hypothesises that this may have been something to do with the issue as it doesn’t seem to happen any other situation.

The custom dictation interface displays what microphone it is listening on when you are using it. Does it change when connected to your car, or still use the built-in mic?

I believe it stays as built in mic