Create Omnifocus in s specific project subfolder?

Hi guys

im trying as the title says to quick create an Omnifocus task in a specific project subfolder

ie here in Projects>Home>Garden

image

i thought the way to go is the URL scheme and tried this

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]?target=/folder/Home/Garden

but this is obviously wrong as it just dumps it in the inbox

any tips on how to proceed?

thx

Z

Maybe this gives you a lead to the solution.
I do not any longer use OmniFocus actively (I am on Things now)
But I clearly remember, that the naming in OmniFocus had some quirks for me.

I found that post with the following excerpt, following this the target parameter should start with /task and not with /folder.

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]?target=/task/Home/Garden

Hence you want to create an item in a project.

URL Schemes - Inside OmniFocus

Paste has a few extra parameters that can direct the data to a specific spot:

target (can be inbox or projects for top-level items; use target=/task/task-id (for a specific action), target=/task/project-name (for a specific project), or target=/folder/folder-name (for a specific folder))
index (positive integers count forward from beginning, while negative numbers count back from the end of list)
content (TaskPaper string, the content to paste; without this parameter, OmniFocus captures text from the system clipboard)
If simply activating omnifocus:///paste without any of the above, the clipboard will be parsed and added to your Inbox.

thx so much @Andreas_Haberle!

your example dosent seem to work for me. I get the error

Invalid URL in generated by CallbackURL step template.

anyone has any clue?

thx

Z

You can only have one question mark. Try changing the second one to an ampersand like this.

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]&target=/task/Home/Garden

Thanks. I copiedit from above an did not check it for validity.

One option to get a specific place in omnifocus is to press them share button and use the generated url. But the project name will be an id like:
omnifocus:///task/m5Cb2dBpxQF,pzJId3i8Jm1,k3AIKQqfzUa,o2OHS4y_qAT,dPo3VCL4MKy

Ha didn’t know about the ampersand thx @sylumer

i tried this

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]&target=/task//Home/Garden

yet it still dosent work and gives the same error:

image

also tried @Andreas_Haberle suggestion

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]&target=/task/iAOLNzVWrPI

but that also gave me the same error

The question mark starts the list of parameters in a URL query. The ampersand is used to add the next parameter in the query.

I’m not sure why you have the extra forward slash between task and Home. But that should get resolved down to a single slash anyway.

When I try this in a callback step, it populates OmniFocus for me.

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]&target=/Personal//To%20Read

So is it your data, or is it your action that is to blame?

Try removing the target part of the URL and see if you can create a task.

If the task is created, you know it is the target that is wrong. Probably some misspelling, or using the wrong character case, of your path is wrong (e.g. do you have a top level called ‘task’ in which ‘Home’ sits?)

If it fails, then that would suggest that there is something in your data that the URL execution is balking at. I would check that you have enabled the option to URL encode tags in the action step, and if you have, perhaps post some example of failing content and a link to your action (you can share it without making it public on the action directory); then we can analyse what is actually going on.

Hope that helps.

that is strange. OmniFocus documentation (see the quote in my post) says that it should be prefixed with /task and /project
but @sylumer has a working omnifocus so I think the blog quote my pe misleading.

@zeltak have you posted a question on the Omnifocus Community or to Omnifocus themselves. the price of the app should give them time to a better documentation as I found on the web.

But I am shure they love to help!

Something like https://culturedcode.com/things/support/articles/2803573/

that might help

https://inside.omnifocus.com/url-schemes

thx yfor your very detailed help and generous help

yeah the extra slash was a mistype

so funny enough what you pasted gives me the same error

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]&target=/Personal//To%20Read

but this

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]&target=/Home/Garden

will actually popup an Omnifocus window

image

as opposed to just quietly send it to the actual folder in the background

now im really confused :smiley: :smiley:

i did that (omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]) but then issuing the action just pops up an empty Omnifocus window with non of the draft actual text

image

@Andreas_Haberle, thx for the links

As per your suggestion ive pasted on the Omnifocus forum

thx guys

Z

Presumably because you don’t have those projects and I do. I wouldn’t expect it to work for you as is. It was just to show you the structure was the same and that it worked.


If you want to save it automatically, add the auto save parameter as true to the end of your URL.

&autosave=true

It is never going to do it quietly in the background. That isn’t how URL schemes work, That’s why to do stuff in the background, developers have to develop special actions for Shortcuts to use where it does not end up having to jump back to the app to execute.

Because it is an x-callback-url call though, you should just get app switching and end up back where you started, in Drafts.

Does that cover everything?

thx @sylumer that helped a lot!

so to update this is the final method that worked

omnifocus://x-callback-url/add?name=[[title]]&note=[[body]]&project=Garden&autosave=true

best and thx to all

Z

so the folder needs not to be set at all.
good to know