Create new draft with Shortcuts

I created this iOS Shortcut to create a new draft with a template. It will append text throughout the day. It works fine from my phone. On my watch, if I run it after the daily draft is already created, it works. However, if I run the shortcut from my watch for the first time in a day, the resulting draft shows “–blank–”. Any suggestions on what is going on?

Can you repost a link to your shortcut? I am getting an error I’ve not seen before when trying to open from the link.

Sure, here is the iCloud link again:

I get the same result :pensive:

Anyone else out there able to open it, or is it just me?

@djs71a can I also check what OS version you are sharing from. If you are on a new developer beta, I imagine my phone would have trouble with that for example.

I’m getting the same error message as @sylumer when clicking on the link.

1 Like

Very odd! I am on iOS 16.5. I can paste screenshots of the shortcut if that helps.

I don’t know if this is the problem, but I’ve seen a Shortcuts bug recently with parameter passing when a shortcut is run from the Watch. Try adding a “Set Variable” step after your Text step in the “Otherwise” block, so your template gets assigned to a variable — then, use that variable value in the “Create Draft” action. See if that allows it to work properly.

1 Like

That did the trick! Thanks for the tip @agiletortoise

1 Like

Just as a follow-up to the issue with opening links to Shortcuts, Matthew Cassinelli tooted this on Mastadon. It seems there is a widespread problem at the moment.