'Create Draft' Shortcuts action behaves differently on iPhone, Mac, Watch

I have this Shortcut running on Mac, iPhone, and Apple Watch:

When run, they give different results:

Device Includes Date Adds Tag
Watch :x: :white_check_mark:
Mac :white_check_mark: :x:
iPhone :white_check_mark: :white_check_mark:


Any ideas what’s going on here?
Mac is on 40.1 (346), iPhone is on 40.1.1

Pardon the terse post, if there’s any other information I can provide please let me know.

Could you share the actual shortcut?

Here’s an iCloud link.

Well…did quick tests. We’re definitely in the “fun with Shortcuts” zone here. You didn’t mention what OS versions you are running, which also might have some effects.

I’m on macOS 14, iOS 17.0.3, watchOS 10.0.2.

For me, I get the following results:

  • iOS
    • Works as expected.
  • macOS
    • Dictate text step just doesn’t work right. It flashes the dictate screen and immediately goes away before listening for any input (tried with another shortcut with the “Dictate text” step, and it fails in the same way). Joy. It does, however, format the date and create the draft with tag assigned, as if I had dictated nothing.
  • watchOS
    • Dictate works.
    • Result is placed in the clipboard on the iPhone, because watchOS doesn’t have a clipboard, so Shortcuts is running that on the phone.
    • Creates draft, and it’s using the template, because the dictated text is after two blank lines, but Shortcuts is not generating the formatted date, so the first line is blank. Tags are assigned.

I don’t see a place here that Drafts is failing. Not sure why you wouldn’t be getting the tag assigned on Mac, but if you are on a different OS, I’d have to test there - there might be some regressions on past OS versions.

I’m on:

  • macOS 12.6.3
  • iOS 17.0.3
  • watchOS 10.0.2

Sounds like we’re getting the same results on iOS and watchOS where we’re both up to date.

It makes sense that my older version of macOS is causing some difference, but honestly I’ll take working dictation over tags!

Thanks for looking into it.

Just in case anyone is following this later, here’s an updated Shortcut that works (for me) on all three devices:

This is a more Drafts-centric approach, so I’m not surpised it’s more reliable :wink:

Two strange things:

  • tagging on the Mac somehow started working. At first I added the second replace-dictated tag in the Update action and it worked, then I changed the tag in the Create action from dictatedcreate-dictated and it started working. I’ll never really use this Shortcut on the Mac anyway, so I don’t care to investigate further.
  • This worked on macOS and iOS on the first try, but it was giving a “missing required parameters” error on watchOS. Below the “Stop this shortcut” action, you’ll see some “Show Results” actions. Placing some combination of those “Show Results” in their respective places solved the problem (for some reason), and then (for some different, more confusing reason) after taking them back out one at a time, it just started working! I’ve left them at the end just in case someone else runs into the same error on watchOS.