Couldn't log in Evernote-China

evernote

#1

Description: couldn’t redirect to the login page of Evernote-china when using the actions asked for authorization.

Have reported to @greg in the Slack channel already. Still not fixed yet. I post it here to confirm if this is an exclusive issue for me.


#2

Been making some tweaks to fix this, but it’s hard for me to test completely not being in China. It’s been a repeated problem over the years, but I’m not sure what’s different in Drafts 5 from 4 at the moment that is causing a hang up. I do have one other beta tester reporting the login issue - but I’m not sure if I have any connecting successfully or not.


#3

Just tested 0.9.1.15, still the same issue. Anyway really appreciate it and it’s good to know it has been working on.


#4

Have you ever thought of rolling back the way of service management to d4? Since the former one is stable and offer a neat interface to manage the account.


#5

The new system in Drafts 5 is much more flexible and consistent. The only service not using the new system is Evernote, the one you have trouble with, which is using the authentication process in the SDK Evernote provides - which I’ve had a lot of problems with over the years, especially related to Evernote China login. It’s been broken in Drafts 4 many times over the years, as well.

I’m sure we’ll sort out the issue soon. Once it app is out I’ll be able to get more data point from Chinese users and try to track down the issue.


#6

Please try Evernote China login again. Evernote claims they resolved an issue at their end with the app being enabled on the China service and it should work now.


#7

The issue has been fixed, thanks for your attention!