Changes to Markdown Table Processing?

Drafts has stopped formatting tables for me. This text has formatted as a table when viewed in Preview in the past:

Date Show Episode Time Length
07/03/2022 A Word test 1 31:43

It is no longer interpreted as a table in Markdown, MultiMarkdown or GitHub Markdown. Has something changed? Do I need to do something different to create a table in Markdown?

Many thanks,
Heather

2 Likes

That content is rendering as a table in previews for me. Have you made any changes to the options in Settings > Markdown recently? There are options in there (like “Markdown Compatibility Mode” for MultiMarkdown) that would disable table extensions.

Can you post your Markdown, enclosed by backticks, here?

Thanks.

I have not made any changes in settings recently. Turning Compatibility Mode on or off has no effect.

I toggled all the settings off, also to no avail. I posted a new table in response to @martinpacker below. I appreciate all the responses.

A few other interesting tests:

  • If I use the “Copy as Rich Text” action and paste into an app that accepts rich text, the table formats properly.
  • However, if I use the “Print - Markdown” action, the printed result is NOT properly formatted.
  • It is still not formatting as a table using Print Preview.

Here is a table that will not render with Preview but does render properly if I use the “Copy as Rich Text” Action

| Date | Show | Episode | Time | Length |
| ------- | ------- | ------------ | :--------: | :--------: |
| 07/1/2022 | The TK Show | Senior Sports Columnist Marcus Thompson | 3 | 52:04 |
| 07/03/2022 | Warriors All-82 | Free Agency Thoughts | 2 | 31:01 |
| 07/04/2022 | First Draft | Tsering Yangzom Lama | 1 | 49:45 |
| 07/04/2022 | KEXP | Coco Peila: Remeber | 2 | 3:27 |
| 07/04/2022 | Today's Top Tune | Early James: Harder To Blame | 3 | 4:05 |

Just pasted that table example in and did a preview and a print, and it is working fine here using either MultiMarkdown (settings as shown), or GitHub as my rendering preferences in both preview and print output.

Not sure what is different.

So weird. I’ll keep testing.

I have a 2020 iMac and a 2015 MacBook Pro. The behavior is the same on both machines. It’s something about my config, but not sure yet.

I appreciate the validation that he markdown text is formatted properly.

The only thing that has changed recently is that I got an Apple Extended TouchID keyboard (even though the TouchID doesn’t work on my Intel iMac). I kept inadvertently switching the keyboard input to Unicode Hex Input until I figured out how to turn it off.

I pasted the text into BBEdit and there are no line breaks — it displays a “¿” where the line breaks should be. Could that be related?

That could definitely do it. Try running the “Zap Gremlins” command in BBEdit’s “Text” menu on it and clean up bad characters, then try again.