Auto-match double-quote not working for me

Auto-match of " is not working for me. It works for all the other characters (),{},, and <>. Am I missing something? The setting implies that it should work for " as well.

Doesn’t work for me either. Both my iPad & iPhone only show single " and ’

Do you also have “Smart Quotes” enabled? Matching of quotes is not compatible with smart quotes.

Smart Quotes was off on my iPad but switched “on” on my iPhone. Switching Smart Quotes off on my iPhone allows auto-match for ". Switching off Smart Quotes on my iPad didn’t enable auto-match for ". Usually use an external keyboard on my iPad but neither the external keyboard nor the screen keyboard generate auto-match ".

An external keyboard for my iPhone also generates auto-match " so the problem appears to be confined to the iPad

I need to correct previous statements. It seems the settings on my devices were out of sync and having gone back to my iPad (where I saw Smart Quotes off) I saw the Smart Quotes switched on and having switched them off (to match my phone) auto-match for " works on both devices.

I knew it was something simple. When I turn off Smart Quotes that auto-match also matches the quote.

I am rather fond of smart quotes. I guess I will keep that option.