Starting to see "Unsupported Syntax" errors - what did I mess up?

I’ve started seeing these errors in macOS (Big Sur 11.3.1) for most drafts that get created on either my iPad or iPhone:

I’m running Drafts 26.3.5. Any clue what I’m doing wrong?

You deleted a custom syntax definition. When you try to open a draft which was assigned to that syntax, it cannot be found and applied to the draft, therefore you need to select an alternate syntax from those available in your installation.

I expect, in this case, you have the default syntax for new drafts on iOS set to this syntax you deleted…which is problematic. Change that selection in Editor Preferences (Aa).

Thanks. I had “Draftsdown” custom syntax on iPadOS but not desktop. Just reverted to Markdown for all.

Syntaxes should sync. How did you have it on one and not the other?

I have no idea how. After deleting Draftsdown, I added it again on my iPad and it synched over just fine. ¯\_(ツ)_/¯