[Solved] Smart quotes - how to?

Hi,
I’m using Drafts 22 on iPadOS 14. Turned on smart quotes in the editor and MultiMarkdown settings. However, when I type “…”, I just get these same straight quotes instead of opening/closing ones.
Any other preference I slid activate or do I just misunderstand the feature?

The processor settings apply to conversion for things like preview, so that would not affect it.

The editor settings will affect it.

At an OS level the general keyboard “Smart Punctuation” should be turned on.

Another thing that can affect it is the soft keyboard you are using. For example, I don’t tend to use the standard Apple keyboard and to access smart quotes I have to tap and hold, then select a double quote variation. If I switch to the standard keyboard with the same settings, smart quotes appear automatically.

Hopefully, something in that will unlock them for you.

In fact, switching from Gboard to the standard Apple keyboard changed everything. Smart punctuation is turned on. Thanks for solving it!

Now I have smart quotes but no glide typing unless I minimize the keyboard. The work is not perfect

I just switched over to Gboard to try accessing smart quotes, and if you press and hold (not a hard press, which switches to cursor moving), you get access to smart quotes.

Thanks for getting back to me. The weird thing: this works exactly as you describe it on the iPhone. On the iPad, however, I only get smart quotes by long pressing for single quotes. Double quotes stubbornly remain un-smart and offer no choice. Tried with the English, German and Spanish variant of Gboard.
I will jus swipe away and use a regexp to change the quotes later.

I was on a school run when I tried that earlier, so I’d only tried it on my phone. Just tried it on my iPad now and I have exactly the same result as you. That has to be an omission on Google’s part.