New User Question re Quote Marks and Justification

Not sure whether this is a bug or some markdown thing I’m unaware of, but whenever I start a line with a quotation mark("), the line justifies far right instead of left. I remove the mark, justifies left as usual. On the off chance, I turned off smart quotes in preferences, but no effect…

Look forward to using this app more and more. Thanks — JM

If you type just one more character after the quote, it will move back to the left. (I don’t know if this is a bug or an obscure feature, either.)

It’s an obscure bug. I thought I had shipped a fix for it, but I guess not, will double check. What platform/version?

(It relates to Apple’s language identification algorithms incorrectly identifying the quote as arabic)

I’m using iPhone with iOS 13.4.1
Drafts 20.0.23
I verified it’s still occurring.

1 Like

Ola - Thanks for the swift reply. In my case typing further characters after the quote does not cause line to justify left. I’m running Catalina 10.15.4. I first noticed the issue using Drafts 17.2.5 , but issue persists with Drafts 20.0.3. As one who long ago encouraged a MAC OS version, I’ve been thrilled to see it happen! All Best – JM

FYI, I did fix this issue. Sort of…it’s fixed unless you have smart quotes enabled. Will fix for that case in the next update.

Ola - I disabled smart quotes in both the MultiMarkdown and Github panels and the same behavior occurs. I also switched off smart quotes at the system preferences level. I restarted the program, although have not restarted the computer. Will try that when have more time. (Catalina 10.15.4. I first noticed the issue using Drafts 17.2.5 , but issue persists with Drafts 20.0.3.) Thanks again - JM

FYI Restarted computer… problem persists. Onwards — JM

Confirmed fix in Drafts XX (love the name) on iOS. Thank you.

Oops. That’s what I get for posting on my first cup of coffee.