Keyboard pops up when it shouldn’t

I am trying to use Drafts for my task management and have a Shortcut that brings up by “Work Tasks” workspace. If I don’t have Focus Mode on, it seems to first create a new draft, then apply the workspace and open the list of drafts on the left side. This means the keyboard pops up and covers half of the list of drafts.

In the app settings, have you got launch in focus mode enabled or disabled? Focus mode should disable creation of new drafts.

in the editor settings, do you have edit on draft selection selected?

I have it off, since I only launch into specific workspaces from the widget or a Shortcut on my homescreen. I still find launching Drafts into a new draft helpful sometimes.

I do have “edit on draft selection” enabled.

I suspect the behavior I described may be a bug, because this morning when I executed the Shortcut, this time the keyboard did not pop up, despite Focus Mode still being off.

Anyway, for the time being it seems the keyboard isn’t popping up anymore, so I guess I no longer have a problem.

Thanks for the response!